3fd5a9a568
Update ov5640 autofocus related patch. We had it working with Martijn's patch in 5.9.1_git20201019-r2 (MR 1654), but then dropped the patch in favor of the patch that was added to megi's tree in 5.9.3_git20201101 (MR 1678). It turns out that the patch added to megi's tree was different than the patch we were carrying, it was a WIP version where loading the autofocus firmware did not work anymore. Megi decided to drop the autofocus patch from his tree for now, as the firmware uploader takes more time in Martijn's proper patch. According to Martijn it takes about a second, which seems reasonable for the postmarketOS use case. I've added the previous version again as out-of-tree patch. Martijn found that for some reason the continuous autofocus still doesn't want to start with this kernel and current patch version, as for some reason the firmware load fails. But he extended the patch to make autofocus work again with "tap to focus" at least. 0005-dts-pinephone-Disable-flash-led-in-OV5640-node.patch is not needed anymore, the same change is in megi's tree. Co-Authored-By: Martijn Braam <martijn@brixit.nl> [ci:skip-build]: already built successfully in CI
61 lines
2 KiB
Diff
61 lines
2 KiB
Diff
From 33212e529708fd480eaf9cc76579f8e7044c0505 Mon Sep 17 00:00:00 2001
|
|
From: Martijn Braam <martijn@brixit.nl>
|
|
Date: Tue, 20 Oct 2020 14:42:01 +0200
|
|
Subject: [PATCH] dts: add pinetab-dev (old display panel)
|
|
|
|
---
|
|
arch/arm64/boot/dts/allwinner/Makefile | 1 +
|
|
.../dts/allwinner/sun50i-a64-pinetab-dev.dts | 29 +++++++++++++++++++
|
|
2 files changed, 30 insertions(+)
|
|
create mode 100644 arch/arm64/boot/dts/allwinner/sun50i-a64-pinetab-dev.dts
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/Makefile b/arch/arm64/boot/dts/allwinner/Makefile
|
|
index a21cfdd8924d..2936092002b5 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/Makefile
|
|
+++ b/arch/arm64/boot/dts/allwinner/Makefile
|
|
@@ -15,6 +15,7 @@ dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pinephone-1.0.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pinephone-1.1.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pinephone-1.2.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pinetab.dtb
|
|
+dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pinetab-dev.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-sopine-baseboard.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-teres-i.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-h5-bananapi-m2-plus.dtb
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-pinetab-dev.dts b/arch/arm64/boot/dts/allwinner/sun50i-a64-pinetab-dev.dts
|
|
new file mode 100644
|
|
index 000000000000..1e287f2fb9f3
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-pinetab-dev.dts
|
|
@@ -0,0 +1,29 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
|
|
+/*
|
|
+ * Copyright (C) 2019 Icenowy Zheng <icenowy@aosc.xyz>
|
|
+ *
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "sun50i-a64-pinetab.dts"
|
|
+
|
|
+/ {
|
|
+ model = "PineTab";
|
|
+ compatible = "pine64,pinetab", "allwinner,sun50i-a64";
|
|
+};
|
|
+
|
|
+&dsi {
|
|
+ vcc-dsi-supply = <®_dldo1>;
|
|
+ status = "okay";
|
|
+
|
|
+ panel@0 {
|
|
+ compatible = "feixin,k101-im2ba02";
|
|
+ reg = <0>;
|
|
+ avdd-supply = <®_dc1sw>;
|
|
+ dvdd-supply = <®_dc1sw>;
|
|
+ cvdd-supply = <®_ldo_io1>;
|
|
+ reset-gpios = <&pio 3 24 GPIO_ACTIVE_HIGH>; /* PD24 */
|
|
+ backlight = <&backlight>;
|
|
+ };
|
|
+};
|
|
--
|
|
2.25.4
|
|
|