8c2a95dbe2
* Mir starts up and is able to display system settings * x86_64 only for now, because at least ubuntu-app-test did not build on aarch64 Based on PureTryOut's work. Getting it to this stage was a huge effort (as it shows in the package count: 111(!)). See the merge request for details. [skip ci]: this won't finish in CI; ollieparanoid made sure that everything builds for x86_64.
39 lines
1.6 KiB
Diff
39 lines
1.6 KiB
Diff
From bd27207eba5211e106129b79be138e5298c9b3cb Mon Sep 17 00:00:00 2001
|
|
From: Luca Weiss <luca@z3ntu.xyz>
|
|
Date: Wed, 3 Oct 2018 17:07:21 +0200
|
|
Subject: [PATCH 1/5] Adapt to QtPim API changes
|
|
|
|
---
|
|
debian/control | 2 +-
|
|
src/UbuntuToolkit/adapters/alarmsadapter_organizer.cpp | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/debian/control b/debian/control
|
|
index 97964424e..800892f62 100644
|
|
--- a/debian/control
|
|
+++ b/debian/control
|
|
@@ -52,7 +52,7 @@ Build-Depends: accountsservice,
|
|
qtdeclarative5-private-dev,
|
|
qtdeclarative5-unity-action-plugin (>= 1.1.0),
|
|
qtmultimedia5-doc-html,
|
|
- qtpim5-dev,
|
|
+ qtpim5-dev (>= 5.0~git20171109~0bd985b),
|
|
qtscript5-doc-html,
|
|
qtsvg5-doc-html,
|
|
qtsystems5-dev,
|
|
diff --git a/src/UbuntuToolkit/adapters/alarmsadapter_organizer.cpp b/src/UbuntuToolkit/adapters/alarmsadapter_organizer.cpp
|
|
index 72e30ba12..7552142f2 100644
|
|
--- a/src/UbuntuToolkit/adapters/alarmsadapter_organizer.cpp
|
|
+++ b/src/UbuntuToolkit/adapters/alarmsadapter_organizer.cpp
|
|
@@ -420,7 +420,7 @@ AlarmsAdapter::AlarmsAdapter(AlarmManager *qq)
|
|
QStringLiteral("collection-type"), QStringLiteral("Task List"));
|
|
if (!manager->saveCollection(&collection)) {
|
|
qWarning() << "WARNING: Creating dedicated collection for alarms was not possible, alarms will be saved into the default collection!";
|
|
- collection = manager->defaultCollection();
|
|
+ collection = manager->collection(manager->defaultCollectionId());
|
|
}
|
|
}
|
|
}
|
|
--
|
|
2.20.1
|
|
|