pmaports/temp/pulseaudio/link-libintl.patch
Dylan Van Assche f9c7ffa9b6
temp/pulseaudio: fork for Bluetooth HFP/HSP support (MR 3080)
PulseAudio is used for handling all audio on postmarketOS.
This also involves Bluetooth audio such as A2DP, HSP and HFP audio.
In the case of HFP/HSP, the HF and AG can interact with each other
through AT commands defined in the Bluetooth HFP 1.8 spec.

This set of patches implements HFP support to allow Bluetooth devices
to accept/reject/hangup calls, dial numbers, DTMF tone generation,
query signal strength, roaming status, service status, AG battery level,
call status, etc.

More details in the upstream MR:
https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/693

Available in edge for testing this merge request with a broader user
base. Not intended for backporting to stable branches.

[ci:skip-build]: already built successfully in CI
2022-06-16 09:33:35 +02:00

30 lines
895 B
Diff

diff --git a/meson.build b/meson.build
index 658eeee..349752e 100644
--- a/meson.build
+++ b/meson.build
@@ -307,6 +307,12 @@ else
libintl_dep = cc.find_library('intl')
endif
+if cc.has_function('libintl_dgettext')
+ libintl_dep = []
+else
+ libintl_dep = cc.find_library('intl')
+endif
+
# Symbols
if cc.has_header_symbol('signal.h', 'SIGXCPU')
diff --git a/src/pulse/meson.build b/src/pulse/meson.build
index aaebff5..3f68ac3 100644
--- a/src/pulse/meson.build
+++ b/src/pulse/meson.build
@@ -84,7 +84,7 @@ libpulse = shared_library('pulse',
dependencies : [libm_dep, thread_dep, libpulsecommon_dep, dbus_dep, dl_dep, iconv_dep, libintl_dep],
implicit_include_directories : false)
-libpulse_dep = declare_dependency(link_with: libpulse)
+libpulse_dep = declare_dependency(link_with: libpulse, dependencies: libintl_dep)
install_headers(
libpulse_headers, 'simple.h',