pmaports/device/testing/linux-samsung-zeroltexx/03-fix-fimc-is-firmware-path.patch
Stefan 4c0ec94eb4
samsung-zeroltexx: new device Samsung Galaxy S6 edge (G925F) (MR 2105)
Port based on an unofficial LineageOS port
from https://www.los-legacy.de/17.1/zerofltexx, using kernel from
https://github.com/Exynos7420/android_kernel_samsung_exynos7420/

What works:
- Kernel boots
- Display and touch input (tested with Weston)
- USB networking
- Wifi

For now only including Wifi drivers, as I wasn't yet able to
successfully test audio and camera subsystems (but I intentionally left
these firmware files commented out in the APKBUILD file).

[ci:skip-build]: already built successfully in CI
2021-06-09 00:23:48 +02:00

11 lines
540 B
Diff

--- a/drivers/media/platform/exynos/fimc-is/fimc-is-sec-define.h
+++ b/drivers/media/platform/exynos/fimc-is/fimc-is-sec-define.h
@@ -103,7 +103,7 @@
#define FIMC_IS_2P2_SETF "setfile_2p2.bin"
#define FIMC_IS_COMPANION_MASTER_SETF "companion_master_setfile.bin"
#define FIMC_IS_COMPANION_MODE_SETF "companion_mode_setfile.bin"
-#define FIMC_IS_FW_PATH "/system/vendor/firmware/"
+#define FIMC_IS_FW_PATH "/lib/firmware/postmarketos/"
#define FIMC_IS_FW_DUMP_PATH "/data/"
#define FIMC_IS_FW_BASE_MASK ((1 << 26) - 1)