69 lines
2.9 KiB
Diff
69 lines
2.9 KiB
Diff
From 81735c7800b3369361c40103d6d479239fa779d7 Mon Sep 17 00:00:00 2001
|
|
From: Ariadne Conill <ariadne@dereferenced.org>
|
|
Date: Fri, 21 Aug 2020 07:03:42 +0000
|
|
Subject: [PATCH] DP: Use --push-state/--pop-state for gold as well when
|
|
linking libtsan.
|
|
|
|
---
|
|
gcc/gcc.c | 16 ++++++++--------
|
|
1 file changed, 8 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/gcc/gcc.c b/gcc/gcc.c
|
|
index 6920bec0fa0..40e07354b3d 100644
|
|
--- a/gcc/gcc.c
|
|
+++ b/gcc/gcc.c
|
|
@@ -696,10 +696,10 @@ proper position among the other output files. */
|
|
#define LIBASAN_SPEC STATIC_LIBASAN_LIBS
|
|
#elif defined(HAVE_LD_STATIC_DYNAMIC)
|
|
#define LIBASAN_SPEC "%{static-libasan:" LD_STATIC_OPTION "}" \
|
|
- " %{!static-libasan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " %{!static-libasan:--push-state --no-as-needed}" \
|
|
" -lasan " \
|
|
" %{static-libasan:" LD_DYNAMIC_OPTION "}" \
|
|
- " %{!static-libasan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
+ " %{!static-libasan:--pop-state}" \
|
|
STATIC_LIBASAN_LIBS
|
|
#else
|
|
#define LIBASAN_SPEC "-lasan" STATIC_LIBASAN_LIBS
|
|
@@ -717,10 +717,10 @@ proper position among the other output files. */
|
|
#define LIBTSAN_SPEC STATIC_LIBTSAN_LIBS
|
|
#elif defined(HAVE_LD_STATIC_DYNAMIC)
|
|
#define LIBTSAN_SPEC "%{static-libtsan:" LD_STATIC_OPTION "}" \
|
|
- " %{!static-libtsan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " %{!static-libtsan:--push-state --no-as-needed}" \
|
|
" -ltsan " \
|
|
" %{static-libtsan:" LD_DYNAMIC_OPTION "}" \
|
|
- " %{!static-libtsan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
+ " %{!static-libtsan:--pop-state}" \
|
|
STATIC_LIBTSAN_LIBS
|
|
#else
|
|
#define LIBTSAN_SPEC "-ltsan" STATIC_LIBTSAN_LIBS
|
|
@@ -738,10 +738,10 @@ proper position among the other output files. */
|
|
#define LIBLSAN_SPEC STATIC_LIBLSAN_LIBS
|
|
#elif defined(HAVE_LD_STATIC_DYNAMIC)
|
|
#define LIBLSAN_SPEC "%{static-liblsan:" LD_STATIC_OPTION "}" \
|
|
- " %{!static-liblsan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " %{!static-liblsan:--push-state --no-as-needed}" \
|
|
" -llsan " \
|
|
" %{static-liblsan:" LD_DYNAMIC_OPTION "}" \
|
|
- " %{!static-liblsan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
+ " %{!static-liblsan:--pop-state}" \
|
|
STATIC_LIBLSAN_LIBS
|
|
#else
|
|
#define LIBLSAN_SPEC "-llsan" STATIC_LIBLSAN_LIBS
|
|
@@ -757,10 +757,10 @@ proper position among the other output files. */
|
|
" %{static-libubsan|static:%:include(libsanitizer.spec)%(link_libubsan)}"
|
|
#ifdef HAVE_LD_STATIC_DYNAMIC
|
|
#define LIBUBSAN_SPEC "%{static-libubsan:" LD_STATIC_OPTION "}" \
|
|
- " %{!static-libubsan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " %{!static-libubsan:--push-state --no-as-needed}" \
|
|
" -lubsan " \
|
|
" %{static-libubsan:" LD_DYNAMIC_OPTION "}" \
|
|
- " %{!static-libubsan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
+ " %{!static-libubsan:--pop-state}" \
|
|
STATIC_LIBUBSAN_LIBS
|
|
#else
|
|
#define LIBUBSAN_SPEC "-lubsan" STATIC_LIBUBSAN_LIBS
|
|
--
|
|
2.31.0
|
|
|