pmaports/temp/gnome-control-center/0001-Hide-and-disable-building-printer-panel.patch
Pablo Correa Gómez 5411328605
temp/gnome-control-center: use upstream as source (MR 2552)
Purism's g-c-c fork is stuck in version 3.38. This has
multiple problems, including carrying old unnecessary
patches and producing some incompatibility with newer
GNOME releases available in Alpine. In consequence,
we fetch the source from upstream and only apply those
patches that make sense for our usecase. When the Purism
patches apply without issues, then we fetch them directly
from their repo.
2021-11-02 21:40:59 +01:00

61 lines
2.3 KiB
Diff

From 4c467035e7f541cbe5d523497488caffecb61663 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Pablo=20Correa=20G=C3=B3mez?= <ablocorrea@hotmail.com>
Date: Sun, 18 Jul 2021 20:53:01 +0200
Subject: [PATCH 1/8] Hide and disable building printer panel
The printer panel requires `libcups`, which is known to crash
in Alpine: https://gitlab.alpinelinux.org/alpine/aports/-/issues/11937
Opening the printer panel crashes g-c-c and prevents it from
opening again. Hide and do not build the panel until the upstream
issue is fixed
---
panels/meson.build | 1 -
shell/cc-panel-loader.c | 2 --
tests/meson.build | 1 -
3 files changed, 4 deletions(-)
diff --git a/panels/meson.build b/panels/meson.build
index f603db919..9df1ec2a3 100644
--- a/panels/meson.build
+++ b/panels/meson.build
@@ -19,7 +19,6 @@ panels = [
'notifications',
'online-accounts',
'power',
- 'printers',
'region',
'removable-media',
'search',
diff --git a/shell/cc-panel-loader.c b/shell/cc-panel-loader.c
index 67f3f1b46..48c587066 100644
--- a/shell/cc-panel-loader.c
+++ b/shell/cc-panel-loader.c
@@ -51,7 +51,6 @@ extern GType cc_wifi_panel_get_type (void);
extern GType cc_notifications_panel_get_type (void);
extern GType cc_goa_panel_get_type (void);
extern GType cc_power_panel_get_type (void);
-extern GType cc_printers_panel_get_type (void);
extern GType cc_region_panel_get_type (void);
extern GType cc_removable_media_panel_get_type (void);
extern GType cc_search_panel_get_type (void);
@@ -122,7 +121,6 @@ static CcPanelLoaderVtable default_panels[] =
PANEL_TYPE("notifications", cc_notifications_panel_get_type, NULL),
PANEL_TYPE("online-accounts", cc_goa_panel_get_type, NULL),
PANEL_TYPE("power", cc_power_panel_get_type, NULL),
- PANEL_TYPE("printers", cc_printers_panel_get_type, NULL),
PANEL_TYPE("region", cc_region_panel_get_type, NULL),
PANEL_TYPE("removable-media", cc_removable_media_panel_get_type, NULL),
PANEL_TYPE("search", cc_search_panel_get_type, NULL),
diff --git a/tests/meson.build b/tests/meson.build
index d4fe361ef..01f7c923c 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -6,5 +6,4 @@ endif
subdir('interactive-panels')
-subdir('printers')
subdir('info')
--
2.25.1