ca17321f5d
Required for cross compiling 32-bit EFI apps/bootloaders on x86_64 [ci:skip-vercheck] [ci:skip-build]: already built successfully in CI
203 lines
7.3 KiB
Diff
203 lines
7.3 KiB
Diff
From 4fa620d8c3e6730211bfb071eb4c817320491bd0 Mon Sep 17 00:00:00 2001
|
|
From: Khem Raj <raj.khem@gmail.com>
|
|
Date: Fri, 29 Mar 2013 08:59:00 +0400
|
|
Subject: [PATCH 02/35] gcc: poison-system-directories
|
|
|
|
Add /sw/include and /opt/include based on the original
|
|
zecke-no-host-includes.patch patch. The original patch checked for
|
|
/usr/include, /sw/include and /opt/include and then triggered a failure and
|
|
aborted.
|
|
|
|
Instead, we add the two missing items to the current scan. If the user
|
|
wants this to be a failure, they can add "-Werror=poison-system-directories".
|
|
|
|
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
|
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|
|
|
Upstream-Status: Pending
|
|
---
|
|
gcc/common.opt | 4 ++++
|
|
gcc/config.in | 6 ++++++
|
|
gcc/configure | 16 ++++++++++++++++
|
|
gcc/configure.ac | 10 ++++++++++
|
|
gcc/doc/invoke.texi | 9 +++++++++
|
|
gcc/gcc.cc | 2 ++
|
|
gcc/incpath.cc | 21 +++++++++++++++++++++
|
|
7 files changed, 68 insertions(+)
|
|
|
|
diff --git a/gcc/common.opt b/gcc/common.opt
|
|
index 862c474d3c8..64c4277c991 100644
|
|
--- a/gcc/common.opt
|
|
+++ b/gcc/common.opt
|
|
@@ -711,6 +711,10 @@ Wreturn-local-addr
|
|
Common Var(warn_return_local_addr) Init(1) Warning
|
|
Warn about returning a pointer/reference to a local or temporary variable.
|
|
|
|
+Wpoison-system-directories
|
|
+Common Var(flag_poison_system_directories) Init(1) Warning
|
|
+Warn for -I and -L options using system directories if cross compiling
|
|
+
|
|
Wshadow
|
|
Common Var(warn_shadow) Warning
|
|
Warn when one variable shadows another. Same as -Wshadow=global.
|
|
diff --git a/gcc/config.in b/gcc/config.in
|
|
index 4cad077bfbe..0679fbbf4c6 100644
|
|
--- a/gcc/config.in
|
|
+++ b/gcc/config.in
|
|
@@ -236,6 +236,12 @@
|
|
#endif
|
|
|
|
|
|
+/* Define to warn for use of native system header directories */
|
|
+#ifndef USED_FOR_TARGET
|
|
+#undef ENABLE_POISON_SYSTEM_DIRECTORIES
|
|
+#endif
|
|
+
|
|
+
|
|
/* Define if you want all operations on RTL (the basic data structure of the
|
|
optimizer and back end) to be checked for dynamic type safety at runtime.
|
|
This is quite expensive. */
|
|
diff --git a/gcc/configure b/gcc/configure
|
|
index c7b26d1927d..8c46369f73f 100755
|
|
--- a/gcc/configure
|
|
+++ b/gcc/configure
|
|
@@ -1026,6 +1026,7 @@ enable_maintainer_mode
|
|
enable_link_mutex
|
|
enable_link_serialization
|
|
enable_version_specific_runtime_libs
|
|
+enable_poison_system_directories
|
|
enable_plugin
|
|
enable_host_shared
|
|
enable_libquadmath_support
|
|
@@ -1788,6 +1789,8 @@ Optional Features:
|
|
--enable-version-specific-runtime-libs
|
|
specify that runtime libraries should be installed
|
|
in a compiler-specific directory
|
|
+ --enable-poison-system-directories
|
|
+ warn for use of native system header directories
|
|
--enable-plugin enable plugin support
|
|
--enable-host-shared build host code as shared libraries
|
|
--disable-libquadmath-support
|
|
@@ -31753,6 +31756,19 @@ if test "${enable_version_specific_runtime_libs+set}" = set; then :
|
|
fi
|
|
|
|
|
|
+# Check whether --enable-poison-system-directories was given.
|
|
+if test "${enable_poison_system_directories+set}" = set; then :
|
|
+ enableval=$enable_poison_system_directories;
|
|
+else
|
|
+ enable_poison_system_directories=no
|
|
+fi
|
|
+
|
|
+if test "x${enable_poison_system_directories}" = "xyes"; then
|
|
+
|
|
+$as_echo "#define ENABLE_POISON_SYSTEM_DIRECTORIES 1" >>confdefs.h
|
|
+
|
|
+fi
|
|
+
|
|
# Substitute configuration variables
|
|
|
|
|
|
diff --git a/gcc/configure.ac b/gcc/configure.ac
|
|
index 09082e8ccae..5504bf6eb01 100644
|
|
--- a/gcc/configure.ac
|
|
+++ b/gcc/configure.ac
|
|
@@ -7292,6 +7292,16 @@ AC_ARG_ENABLE(version-specific-runtime-libs,
|
|
[specify that runtime libraries should be
|
|
installed in a compiler-specific directory])])
|
|
|
|
+AC_ARG_ENABLE([poison-system-directories],
|
|
+ AS_HELP_STRING([--enable-poison-system-directories],
|
|
+ [warn for use of native system header directories]),,
|
|
+ [enable_poison_system_directories=no])
|
|
+if test "x${enable_poison_system_directories}" = "xyes"; then
|
|
+ AC_DEFINE([ENABLE_POISON_SYSTEM_DIRECTORIES],
|
|
+ [1],
|
|
+ [Define to warn for use of native system header directories])
|
|
+fi
|
|
+
|
|
# Substitute configuration variables
|
|
AC_SUBST(subdirs)
|
|
AC_SUBST(srcdir)
|
|
diff --git a/gcc/doc/invoke.texi b/gcc/doc/invoke.texi
|
|
index af0e5933fdb..b6731a4673c 100644
|
|
--- a/gcc/doc/invoke.texi
|
|
+++ b/gcc/doc/invoke.texi
|
|
@@ -384,6 +384,7 @@ Objective-C and Objective-C++ Dialects}.
|
|
-Wpacked -Wno-packed-bitfield-compat -Wpacked-not-aligned -Wpadded
|
|
-Wparentheses -Wno-pedantic-ms-format
|
|
-Wpointer-arith -Wno-pointer-compare -Wno-pointer-to-int-cast
|
|
+-Wno-poison-system-directories
|
|
-Wno-pragmas -Wno-prio-ctor-dtor -Wredundant-decls
|
|
-Wrestrict -Wno-return-local-addr -Wreturn-type
|
|
-Wno-scalar-storage-order -Wsequence-point
|
|
@@ -8426,6 +8427,14 @@ made up of data only and thus requires no special treatment. But, for
|
|
most targets, it is made up of code and thus requires the stack to be
|
|
made executable in order for the program to work properly.
|
|
|
|
+@opindex Wno-poison-system-directories
|
|
+@item -Wno-poison-system-directories
|
|
+Do not warn for @option{-I} or @option{-L} options using system
|
|
+directories such as @file{/usr/include} when cross compiling. This
|
|
+option is intended for use in chroot environments when such
|
|
+directories contain the correct headers and libraries for the target
|
|
+system rather than the host.
|
|
+
|
|
@opindex Wfloat-equal
|
|
@opindex Wno-float-equal
|
|
@item -Wfloat-equal
|
|
diff --git a/gcc/gcc.cc b/gcc/gcc.cc
|
|
index 16bb07f2cdc..33b56e721d2 100644
|
|
--- a/gcc/gcc.cc
|
|
+++ b/gcc/gcc.cc
|
|
@@ -1146,6 +1146,8 @@ proper position among the other output files. */
|
|
"%{fuse-ld=*:-fuse-ld=%*} " LINK_COMPRESS_DEBUG_SPEC \
|
|
"%X %{o*} %{e*} %{N} %{n} %{r}\
|
|
%{s} %{t} %{u*} %{z} %{Z} %{!nostdlib:%{!r:%{!nostartfiles:%S}}} \
|
|
+ %{Wno-poison-system-directories:--no-poison-system-directories} \
|
|
+ %{Werror=poison-system-directories:--error-poison-system-directories} \
|
|
%{static|no-pie|static-pie:} %@{L*} %(mfwrap) %(link_libgcc) " \
|
|
VTABLE_VERIFICATION_SPEC " " SANITIZER_EARLY_SPEC " %o "" \
|
|
%{fopenacc|fopenmp|%:gt(%{ftree-parallelize-loops=*:%*} 1):\
|
|
diff --git a/gcc/incpath.cc b/gcc/incpath.cc
|
|
index 4d44321183f..0f3f071b44c 100644
|
|
--- a/gcc/incpath.cc
|
|
+++ b/gcc/incpath.cc
|
|
@@ -26,6 +26,7 @@
|
|
#include "intl.h"
|
|
#include "incpath.h"
|
|
#include "cppdefault.h"
|
|
+#include "diagnostic-core.h"
|
|
|
|
/* Microsoft Windows does not natively support inodes.
|
|
VMS has non-numeric inodes. */
|
|
@@ -399,6 +400,26 @@ merge_include_chains (const char *sysroot, cpp_reader *pfile, int verbose)
|
|
}
|
|
fprintf (stderr, _("End of search list.\n"));
|
|
}
|
|
+
|
|
+#ifdef ENABLE_POISON_SYSTEM_DIRECTORIES
|
|
+ if (flag_poison_system_directories)
|
|
+ {
|
|
+ struct cpp_dir *p;
|
|
+
|
|
+ for (p = heads[INC_QUOTE]; p; p = p->next)
|
|
+ {
|
|
+ if ((!strncmp (p->name, "/usr/include", 12))
|
|
+ || (!strncmp (p->name, "/usr/local/include", 18))
|
|
+ || (!strncmp (p->name, "/usr/X11R6/include", 18))
|
|
+ || (!strncmp (p->name, "/sw/include", 11))
|
|
+ || (!strncmp (p->name, "/opt/include", 12)))
|
|
+ warning (OPT_Wpoison_system_directories,
|
|
+ "include location \"%s\" is unsafe for "
|
|
+ "cross-compilation",
|
|
+ p->name);
|
|
+ }
|
|
+ }
|
|
+#endif
|
|
}
|
|
|
|
/* Use given -I paths for #include "..." but not #include <...>, and
|
|
--
|
|
2.41.0
|
|
|