ca17321f5d
Required for cross compiling 32-bit EFI apps/bootloaders on x86_64 [ci:skip-vercheck] [ci:skip-build]: already built successfully in CI
272 lines
11 KiB
Diff
272 lines
11 KiB
Diff
From 67c0f5789630b27149f60ff831999ef7c1dba5d5 Mon Sep 17 00:00:00 2001
|
|
From: Ariadne Conill <ariadne@dereferenced.org>
|
|
Date: Fri, 21 Aug 2020 06:46:56 +0000
|
|
Subject: [PATCH 05/35] On linux targets pass --as-needed by default to the
|
|
linker, but always link the sanitizer libraries with --no-as-needed.
|
|
|
|
---
|
|
gcc/config/aarch64/aarch64-linux.h | 1 +
|
|
gcc/config/alpha/linux-elf.h | 2 +-
|
|
gcc/config/arm/linux-elf.h | 1 +
|
|
gcc/config/gnu-user.h | 6 +++---
|
|
gcc/config/i386/gnu-user.h | 2 +-
|
|
gcc/config/i386/gnu-user64.h | 1 +
|
|
gcc/config/ia64/linux.h | 2 +-
|
|
gcc/config/mips/gnu-user.h | 1 +
|
|
gcc/config/riscv/linux.h | 1 +
|
|
gcc/config/rs6000/linux64.h | 4 ++--
|
|
gcc/config/rs6000/sysv4.h | 2 +-
|
|
gcc/config/s390/linux.h | 2 +-
|
|
gcc/config/sparc/linux.h | 2 +-
|
|
gcc/gcc.cc | 28 ++++++++++++++++++++--------
|
|
14 files changed, 36 insertions(+), 19 deletions(-)
|
|
|
|
diff --git a/gcc/config/aarch64/aarch64-linux.h b/gcc/config/aarch64/aarch64-linux.h
|
|
index 4277f03da2a..b131983a546 100644
|
|
--- a/gcc/config/aarch64/aarch64-linux.h
|
|
+++ b/gcc/config/aarch64/aarch64-linux.h
|
|
@@ -35,6 +35,7 @@
|
|
#define CPP_SPEC "%{pthread:-D_REENTRANT}"
|
|
|
|
#define LINUX_TARGET_LINK_SPEC "%{h*} \
|
|
+ --as-needed \
|
|
%{static:-Bstatic} \
|
|
%{shared:-shared} \
|
|
%{symbolic:-Bsymbolic} \
|
|
diff --git a/gcc/config/alpha/linux-elf.h b/gcc/config/alpha/linux-elf.h
|
|
index 03f783f2ad1..d946e700dda 100644
|
|
--- a/gcc/config/alpha/linux-elf.h
|
|
+++ b/gcc/config/alpha/linux-elf.h
|
|
@@ -37,7 +37,7 @@ along with GCC; see the file COPYING3. If not see
|
|
|
|
#define ELF_DYNAMIC_LINKER GNU_USER_DYNAMIC_LINKER
|
|
|
|
-#define LINK_SPEC "-m elf64alpha %{G*} %{relax:-relax} \
|
|
+#define LINK_SPEC "-m elf64alpha --as-needed %{G*} %{relax:-relax} \
|
|
%{O*:-O3} %{!O*:-O1} \
|
|
%{shared:-shared} \
|
|
%{!shared: \
|
|
diff --git a/gcc/config/arm/linux-elf.h b/gcc/config/arm/linux-elf.h
|
|
index 7b7b7cbbe14..49c050c6f2c 100644
|
|
--- a/gcc/config/arm/linux-elf.h
|
|
+++ b/gcc/config/arm/linux-elf.h
|
|
@@ -70,6 +70,7 @@
|
|
%{rdynamic:-export-dynamic} \
|
|
%{!shared:-dynamic-linker " GNU_USER_DYNAMIC_LINKER "}} \
|
|
-X \
|
|
+ --as-needed \
|
|
%{mbig-endian:-EB} %{mlittle-endian:-EL}" \
|
|
SUBTARGET_EXTRA_LINK_SPEC
|
|
|
|
diff --git a/gcc/config/gnu-user.h b/gcc/config/gnu-user.h
|
|
index eda8010b133..b26b17f2f2a 100644
|
|
--- a/gcc/config/gnu-user.h
|
|
+++ b/gcc/config/gnu-user.h
|
|
@@ -136,7 +136,7 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
|
#define LIBASAN_EARLY_SPEC "%{!shared:libasan_preinit%O%s} " \
|
|
"%{static-libasan:%{!shared:" \
|
|
LD_STATIC_OPTION " --whole-archive -lasan --no-whole-archive " \
|
|
- LD_DYNAMIC_OPTION "}}%{!static-libasan:-lasan}"
|
|
+ LD_DYNAMIC_OPTION "}}%{!static-libasan:%{!fuse-ld=gold:--push-state} --no-as-needed -lasan %{fuse-ld=gold:--as-needed;:--pop-state}}"
|
|
#undef LIBHWASAN_EARLY_SPEC
|
|
#define LIBHWASAN_EARLY_SPEC "%{!shared:libhwasan_preinit%O%s} " \
|
|
"%{static-libhwasan:%{!shared:" \
|
|
@@ -146,12 +146,12 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
|
#define LIBTSAN_EARLY_SPEC "%{!shared:libtsan_preinit%O%s} " \
|
|
"%{static-libtsan:%{!shared:" \
|
|
LD_STATIC_OPTION " --whole-archive -ltsan --no-whole-archive " \
|
|
- LD_DYNAMIC_OPTION "}}%{!static-libtsan:-ltsan}"
|
|
+ LD_DYNAMIC_OPTION "}}%{!static-libtsan:%{!fuse-ld=gold:--push-state} --no-as-needed -ltsan %{fuse-ld=gold:--as-needed;:--pop-state}}"
|
|
#undef LIBLSAN_EARLY_SPEC
|
|
#define LIBLSAN_EARLY_SPEC "%{!shared:liblsan_preinit%O%s} " \
|
|
"%{static-liblsan:%{!shared:" \
|
|
LD_STATIC_OPTION " --whole-archive -llsan --no-whole-archive " \
|
|
- LD_DYNAMIC_OPTION "}}%{!static-liblsan:-llsan}"
|
|
+ LD_DYNAMIC_OPTION "}}%{!static-liblsan:%{!fuse-ld=gold:--push-state} --no-as-needed -llsan %{fuse-ld=gold:--as-needed;:--pop-state}}"
|
|
#endif
|
|
|
|
#undef TARGET_F951_OPTIONS
|
|
diff --git a/gcc/config/i386/gnu-user.h b/gcc/config/i386/gnu-user.h
|
|
index a79b739089d..e0752673dff 100644
|
|
--- a/gcc/config/i386/gnu-user.h
|
|
+++ b/gcc/config/i386/gnu-user.h
|
|
@@ -68,7 +68,7 @@ along with GCC; see the file COPYING3. If not see
|
|
{ "link_emulation", GNU_USER_LINK_EMULATION },\
|
|
{ "dynamic_linker", GNU_USER_DYNAMIC_LINKER }
|
|
|
|
-#define GNU_USER_TARGET_LINK_SPEC "-m %(link_emulation) %{shared:-shared} \
|
|
+#define GNU_USER_TARGET_LINK_SPEC "-m %(link_emulation) --as-needed %{shared:-shared} \
|
|
%{!shared: \
|
|
%{!static: \
|
|
%{!static-pie: \
|
|
diff --git a/gcc/config/i386/gnu-user64.h b/gcc/config/i386/gnu-user64.h
|
|
index 3b63b99acf6..759bf0db86f 100644
|
|
--- a/gcc/config/i386/gnu-user64.h
|
|
+++ b/gcc/config/i386/gnu-user64.h
|
|
@@ -56,6 +56,7 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
|
"%{" SPEC_64 ":-m " GNU_USER_LINK_EMULATION64 "} \
|
|
%{" SPEC_32 ":-m " GNU_USER_LINK_EMULATION32 "} \
|
|
%{" SPEC_X32 ":-m " GNU_USER_LINK_EMULATIONX32 "} \
|
|
+ --as-needed \
|
|
%{shared:-shared} \
|
|
%{!shared: \
|
|
%{!static: \
|
|
diff --git a/gcc/config/ia64/linux.h b/gcc/config/ia64/linux.h
|
|
index 5dfd428aa17..02656dad7fc 100644
|
|
--- a/gcc/config/ia64/linux.h
|
|
+++ b/gcc/config/ia64/linux.h
|
|
@@ -58,7 +58,7 @@ do { \
|
|
#define GLIBC_DYNAMIC_LINKER "/lib/ld-linux-ia64.so.2"
|
|
|
|
#undef LINK_SPEC
|
|
-#define LINK_SPEC "\
|
|
+#define LINK_SPEC " --as-needed \
|
|
%{shared:-shared} \
|
|
%{!shared: \
|
|
%{!static: \
|
|
diff --git a/gcc/config/mips/gnu-user.h b/gcc/config/mips/gnu-user.h
|
|
index a4e5380b589..3cc61bce69f 100644
|
|
--- a/gcc/config/mips/gnu-user.h
|
|
+++ b/gcc/config/mips/gnu-user.h
|
|
@@ -55,6 +55,7 @@ along with GCC; see the file COPYING3. If not see
|
|
#undef GNU_USER_TARGET_LINK_SPEC
|
|
#define GNU_USER_TARGET_LINK_SPEC "\
|
|
%{G*} %{EB} %{EL} %{mips*} %{shared} \
|
|
+ -as-needed \
|
|
%{!shared: \
|
|
%{!static: \
|
|
%{rdynamic:-export-dynamic} \
|
|
diff --git a/gcc/config/riscv/linux.h b/gcc/config/riscv/linux.h
|
|
index 3e625e0f867..f8c2c351e5a 100644
|
|
--- a/gcc/config/riscv/linux.h
|
|
+++ b/gcc/config/riscv/linux.h
|
|
@@ -48,6 +48,7 @@ along with GCC; see the file COPYING3. If not see
|
|
"%{mabi=ilp32:_ilp32}"
|
|
|
|
#define LINK_SPEC "\
|
|
+-as-needed \
|
|
-melf" XLEN_SPEC DEFAULT_ENDIAN_SPEC "riscv" LD_EMUL_SUFFIX " \
|
|
%{mno-relax:--no-relax} \
|
|
%{mbig-endian:-EB} \
|
|
diff --git a/gcc/config/rs6000/linux64.h b/gcc/config/rs6000/linux64.h
|
|
index 9e457033d11..08016bf224d 100644
|
|
--- a/gcc/config/rs6000/linux64.h
|
|
+++ b/gcc/config/rs6000/linux64.h
|
|
@@ -377,13 +377,13 @@ extern int dot_symbols;
|
|
" -m elf64ppc")
|
|
#endif
|
|
|
|
-#define LINK_OS_LINUX_SPEC32 LINK_OS_LINUX_EMUL32 " %{!shared: %{!static: \
|
|
+#define LINK_OS_LINUX_SPEC32 LINK_OS_LINUX_EMUL32 " --as-needed %{!shared: %{!static: \
|
|
%{!static-pie: \
|
|
%{rdynamic:-export-dynamic} \
|
|
-dynamic-linker " GNU_USER_DYNAMIC_LINKER32 "}}} \
|
|
%(link_os_extra_spec32)"
|
|
|
|
-#define LINK_OS_LINUX_SPEC64 LINK_OS_LINUX_EMUL64 " %{!shared: %{!static: \
|
|
+#define LINK_OS_LINUX_SPEC64 LINK_OS_LINUX_EMUL64 " --as-needed %{!shared: %{!static: \
|
|
%{!static-pie: \
|
|
%{rdynamic:-export-dynamic} \
|
|
-dynamic-linker " GNU_USER_DYNAMIC_LINKER64 "}}} \
|
|
diff --git a/gcc/config/rs6000/sysv4.h b/gcc/config/rs6000/sysv4.h
|
|
index ae932fc22f0..c8ff0c6dc8e 100644
|
|
--- a/gcc/config/rs6000/sysv4.h
|
|
+++ b/gcc/config/rs6000/sysv4.h
|
|
@@ -780,7 +780,7 @@ GNU_USER_TARGET_CC1_SPEC
|
|
#define GNU_USER_DYNAMIC_LINKER GLIBC_DYNAMIC_LINKER
|
|
#endif
|
|
|
|
-#define LINK_OS_LINUX_SPEC "-m elf32ppclinux %{!shared: %{!static: \
|
|
+#define LINK_OS_LINUX_SPEC "-m elf32ppclinux --as-needed %{!shared: %{!static: \
|
|
%{rdynamic:-export-dynamic} \
|
|
-dynamic-linker " GNU_USER_DYNAMIC_LINKER "}}"
|
|
|
|
diff --git a/gcc/config/s390/linux.h b/gcc/config/s390/linux.h
|
|
index 02aa1edaff8..64df5801134 100644
|
|
--- a/gcc/config/s390/linux.h
|
|
+++ b/gcc/config/s390/linux.h
|
|
@@ -82,7 +82,7 @@ along with GCC; see the file COPYING3. If not see
|
|
|
|
#undef LINK_SPEC
|
|
#define LINK_SPEC \
|
|
- "%{m31:-m elf_s390}%{m64:-m elf64_s390} \
|
|
+ "%{m31:-m elf_s390}%{m64:-m elf64_s390} --as-needed \
|
|
%{shared:-shared} \
|
|
%{!shared: \
|
|
%{static:-static} \
|
|
diff --git a/gcc/config/sparc/linux.h b/gcc/config/sparc/linux.h
|
|
index 0e33b3cac2c..c2f44546e62 100644
|
|
--- a/gcc/config/sparc/linux.h
|
|
+++ b/gcc/config/sparc/linux.h
|
|
@@ -81,7 +81,7 @@ extern const char *host_detect_local_cpu (int argc, const char **argv);
|
|
#define GLIBC_DYNAMIC_LINKER "/lib/ld-linux.so.2"
|
|
|
|
#undef LINK_SPEC
|
|
-#define LINK_SPEC "-m elf32_sparc %{shared:-shared} \
|
|
+#define LINK_SPEC "-m elf32_sparc --as-needed %{shared:-shared} \
|
|
%{!mno-relax:%{!r:-relax}} \
|
|
%{!shared: \
|
|
%{!static: \
|
|
diff --git a/gcc/gcc.cc b/gcc/gcc.cc
|
|
index f82fae23c22..da6417dd0d1 100644
|
|
--- a/gcc/gcc.cc
|
|
+++ b/gcc/gcc.cc
|
|
@@ -754,8 +754,11 @@ proper position among the other output files. */
|
|
#ifdef LIBASAN_EARLY_SPEC
|
|
#define LIBASAN_SPEC STATIC_LIBASAN_LIBS
|
|
#elif defined(HAVE_LD_STATIC_DYNAMIC)
|
|
-#define LIBASAN_SPEC "%{static-libasan:" LD_STATIC_OPTION \
|
|
- "} -lasan %{static-libasan:" LD_DYNAMIC_OPTION "}" \
|
|
+#define LIBASAN_SPEC "%{static-libasan:" LD_STATIC_OPTION "}" \
|
|
+ " %{!static-libasan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " -lasan " \
|
|
+ " %{static-libasan:" LD_DYNAMIC_OPTION "}" \
|
|
+ " %{!static-libasan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
STATIC_LIBASAN_LIBS
|
|
#else
|
|
#define LIBASAN_SPEC "-lasan" STATIC_LIBASAN_LIBS
|
|
@@ -790,8 +793,11 @@ proper position among the other output files. */
|
|
#ifdef LIBTSAN_EARLY_SPEC
|
|
#define LIBTSAN_SPEC STATIC_LIBTSAN_LIBS
|
|
#elif defined(HAVE_LD_STATIC_DYNAMIC)
|
|
-#define LIBTSAN_SPEC "%{static-libtsan:" LD_STATIC_OPTION \
|
|
- "} -ltsan %{static-libtsan:" LD_DYNAMIC_OPTION "}" \
|
|
+#define LIBTSAN_SPEC "%{static-libtsan:" LD_STATIC_OPTION "}" \
|
|
+ " %{!static-libtsan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " -ltsan " \
|
|
+ " %{static-libtsan:" LD_DYNAMIC_OPTION "}" \
|
|
+ " %{!static-libtsan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
STATIC_LIBTSAN_LIBS
|
|
#else
|
|
#define LIBTSAN_SPEC "-ltsan" STATIC_LIBTSAN_LIBS
|
|
@@ -808,8 +814,11 @@ proper position among the other output files. */
|
|
#ifdef LIBLSAN_EARLY_SPEC
|
|
#define LIBLSAN_SPEC STATIC_LIBLSAN_LIBS
|
|
#elif defined(HAVE_LD_STATIC_DYNAMIC)
|
|
-#define LIBLSAN_SPEC "%{static-liblsan:" LD_STATIC_OPTION \
|
|
- "} -llsan %{static-liblsan:" LD_DYNAMIC_OPTION "}" \
|
|
+#define LIBLSAN_SPEC "%{static-liblsan:" LD_STATIC_OPTION "}" \
|
|
+ " %{!static-liblsan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " -llsan " \
|
|
+ " %{static-liblsan:" LD_DYNAMIC_OPTION "}" \
|
|
+ " %{!static-liblsan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
STATIC_LIBLSAN_LIBS
|
|
#else
|
|
#define LIBLSAN_SPEC "-llsan" STATIC_LIBLSAN_LIBS
|
|
@@ -824,8 +833,11 @@ proper position among the other output files. */
|
|
#define STATIC_LIBUBSAN_LIBS \
|
|
" %{static-libubsan|static:%:include(libsanitizer.spec)%(link_libubsan)}"
|
|
#ifdef HAVE_LD_STATIC_DYNAMIC
|
|
-#define LIBUBSAN_SPEC "%{static-libubsan:" LD_STATIC_OPTION \
|
|
- "} -lubsan %{static-libubsan:" LD_DYNAMIC_OPTION "}" \
|
|
+#define LIBUBSAN_SPEC "%{static-libubsan:" LD_STATIC_OPTION "}" \
|
|
+ " %{!static-libubsan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " -lubsan " \
|
|
+ " %{static-libubsan:" LD_DYNAMIC_OPTION "}" \
|
|
+ " %{!static-libubsan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
STATIC_LIBUBSAN_LIBS
|
|
#else
|
|
#define LIBUBSAN_SPEC "-lubsan" STATIC_LIBUBSAN_LIBS
|
|
--
|
|
2.41.0
|
|
|