9353bca73f
* Created seperate DTB for the devkit named sun50i-a64-dontbeevil.dts so it can easily be edited and the diff remains readable in gitlab * Added patch to build the new dtb * Added the ST LIS3MDL to the new dtb (Magnetometer) * Added the SensorTek STK3335 to the new dtb (Proximity and ambient light sensor) * InvenSense MPU-6050 to the new dtb (Accelerometer and gyroscope) * Added CSI bus and OV5640 camera Remaining issues: * The STK3310 module doesn't load automatically * Camera doesn't want to capture but does show up as /dev/video0 [ci:skip-build]: doesn't finish in time
12 lines
709 B
Diff
12 lines
709 B
Diff
diff --git a/arch/arm64/boot/dts/allwinner/Makefile b/arch/arm64/boot/dts/allwinner/Makefile
|
|
index 0b0917111099..34f686f3b2a0 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/Makefile
|
|
+++ b/arch/arm64/boot/dts/allwinner/Makefile
|
|
@@ -7,6 +7,7 @@ dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-orangepi-win.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pine64-lts.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pine64-plus.dtb sun50i-a64-pine64.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pinebook.dtb
|
|
+dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-dontbeevil.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-sopine-baseboard.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-teres-i.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-h5-bananapi-m2-plus.dtb
|