17dae7d98c
Make it possible to build old kernels with gcc4 for armv7 and aarch64. The packages have been generated with (as usually): $ pmbootstrap aportgen gcc4-aarch64 gcc4-armv7 [ci:skip-build]: I have tested that this builds locally. Fixes #193.
10 lines
342 B
Diff
10 lines
342 B
Diff
--- gcc-4.8.1/Makefile.in.orig
|
|
+++ gcc-4.8.1/Makefile.in
|
|
@@ -169,6 +169,7 @@
|
|
# built for the build system to override those in BASE_FLAGS_TO_PASSS.
|
|
EXTRA_BUILD_FLAGS = \
|
|
CFLAGS="$(CFLAGS_FOR_BUILD)" \
|
|
+ CXXFLAGS="$(CXXFLAGS_FOR_BUILD)" \
|
|
LDFLAGS="$(LDFLAGS_FOR_BUILD)"
|
|
|
|
# This is the list of directories to built for the host system.
|