925b78ae16
* Fix hardcoded `armhf` in pmb/aportgen/binutils.py * Generate aports: `binutils-aarch64`, `musl-aarch64`, `gcc-aarch64` * Distccd: Remember the cross-compiler architecture (currently armhf or aarch64), that the current distccd is running as, and restart distccd with the correct architecture, in case a different arch is needed than what it is currently running as. (Depending on the cross-compiler arch, the PATH variable gets adjusted before starting distccd) * Testcases: add aport generation for aarch64, add cross-compiling to aarch64 * pmb/parse/arch.py: Add aarch64 to the mapping
22 lines
816 B
Diff
22 lines
816 B
Diff
--- gcc-4.8.2/libada/configure.ac.orig 2013-01-14 22:15:04.000000000 +0400
|
|
+++ gcc-4.8.2/libada/configure.ac 2014-01-21 06:53:04.254453731 +0400
|
|
@@ -127,7 +127,7 @@
|
|
AC_PROG_LN_S
|
|
|
|
# Determine what to build for 'gnatlib'
|
|
-if test $build = $target \
|
|
+if true \
|
|
&& test ${enable_shared} = yes ; then
|
|
# Note that build=target is almost certainly the wrong test; FIXME
|
|
default_gnatlib_target="gnatlib-shared"
|
|
--- gcc-4.8.2/libada/configure.orig 2013-10-16 11:27:58.000000000 +0400
|
|
+++ gcc-4.8.2/libada/configure 2014-01-21 06:53:26.727581207 +0400
|
|
@@ -2951,7 +2951,7 @@
|
|
|
|
|
|
# Determine what to build for 'gnatlib'
|
|
-if test $build = $target \
|
|
+if true \
|
|
&& test ${enable_shared} = yes ; then
|
|
# Note that build=target is almost certainly the wrong test; FIXME
|
|
default_gnatlib_target="gnatlib-shared"
|