afd26b3b97
This reverts commit d56a2facfb
and changes the main/gcc6 pkgrel to 9999, so it will always be higher
than Alpine's version.
241 lines
10 KiB
Diff
241 lines
10 KiB
Diff
# DP: On linux targets pass --as-needed by default to the linker, but always
|
|
# DP: link the sanitizer libraries with --no-as-needed.
|
|
|
|
--- a/gcc/gcc.c
|
|
+++ b/gcc/gcc.c
|
|
@@ -568,8 +568,11 @@ proper position among the other output f
|
|
#ifdef LIBTSAN_EARLY_SPEC
|
|
#define LIBTSAN_SPEC STATIC_LIBTSAN_LIBS
|
|
#elif defined(HAVE_LD_STATIC_DYNAMIC)
|
|
-#define LIBTSAN_SPEC "%{static-libtsan:" LD_STATIC_OPTION \
|
|
- "} -ltsan %{static-libtsan:" LD_DYNAMIC_OPTION "}" \
|
|
+#define LIBTSAN_SPEC "%{static-libtsan:" LD_STATIC_OPTION "}" \
|
|
+ " %{!static-libtsan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " -ltsan " \
|
|
+ " %{static-libtsan:" LD_DYNAMIC_OPTION "}" \
|
|
+ " %{!static-libtsan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
STATIC_LIBTSAN_LIBS
|
|
#else
|
|
#define LIBTSAN_SPEC "-ltsan" STATIC_LIBTSAN_LIBS
|
|
--- a/gcc/config/gnu-user.h
|
|
+++ b/gcc/config/gnu-user.h
|
|
@@ -124,13 +124,13 @@
|
|
#define LIBASAN_EARLY_SPEC "%{!shared:libasan_preinit%O%s} " \
|
|
"%{static-libasan:%{!shared:" \
|
|
LD_STATIC_OPTION " --whole-archive -lasan --no-whole-archive " \
|
|
- LD_DYNAMIC_OPTION "}}%{!static-libasan:-lasan}"
|
|
+ LD_DYNAMIC_OPTION "}}%{!static-libasan:%{!fuse-ld=gold:--push-state} --no-as-needed -lasan %{fuse-ld=gold:--as-needed;:--pop-state}}"
|
|
#undef LIBTSAN_EARLY_SPEC
|
|
#define LIBTSAN_EARLY_SPEC "%{static-libtsan:%{!shared:" \
|
|
LD_STATIC_OPTION " --whole-archive -ltsan --no-whole-archive " \
|
|
- LD_DYNAMIC_OPTION "}}%{!static-libtsan:-ltsan}"
|
|
+ LD_DYNAMIC_OPTION "}}%{!static-libtsan:%{!fuse-ld=gold:--push-state} --no-as-needed -ltsan %{fuse-ld=gold:--as-needed;:--pop-state}}"
|
|
#undef LIBLSAN_EARLY_SPEC
|
|
#define LIBLSAN_EARLY_SPEC "%{static-liblsan:%{!shared:" \
|
|
LD_STATIC_OPTION " --whole-archive -llsan --no-whole-archive " \
|
|
- LD_DYNAMIC_OPTION "}}%{!static-liblsan:-llsan}"
|
|
+ LD_DYNAMIC_OPTION "}}%{!static-liblsan:%{!fuse-ld=gold:--push-state} --no-as-needed -llsan %{fuse-ld=gold:--as-needed;:--pop-state}}"
|
|
#endif
|
|
Index: b/gcc/config/aarch64/aarch64-linux.h
|
|
===================================================================
|
|
--- a/gcc/config/aarch64/aarch64-linux.h
|
|
+++ b/gcc/config/aarch64/aarch64-linux.h
|
|
@@ -36,5 +36,6 @@
|
|
|
|
#define LINUX_TARGET_LINK_SPEC "%{h*} \
|
|
+ --as-needed \
|
|
%{static:-Bstatic} \
|
|
%{shared:-shared} \
|
|
%{symbolic:-Bsymbolic} \
|
|
Index: b/gcc/config/ia64/linux.h
|
|
===================================================================
|
|
--- a/gcc/config/ia64/linux.h
|
|
+++ b/gcc/config/ia64/linux.h
|
|
@@ -58,7 +58,7 @@ do { \
|
|
#define GLIBC_DYNAMIC_LINKER "/lib/ld-linux-ia64.so.2"
|
|
|
|
#undef LINK_SPEC
|
|
-#define LINK_SPEC "\
|
|
+#define LINK_SPEC " --as-needed \
|
|
%{shared:-shared} \
|
|
%{!shared: \
|
|
%{!static: \
|
|
Index: b/gcc/config/sparc/linux.h
|
|
===================================================================
|
|
--- a/gcc/config/sparc/linux.h
|
|
+++ b/gcc/config/sparc/linux.h
|
|
@@ -86,7 +86,7 @@ extern const char *host_detect_local_cpu
|
|
#define GLIBC_DYNAMIC_LINKER "/lib/ld-linux.so.2"
|
|
|
|
#undef LINK_SPEC
|
|
-#define LINK_SPEC "-m elf32_sparc %{shared:-shared} \
|
|
+#define LINK_SPEC "-m elf32_sparc --as-needed %{shared:-shared} \
|
|
%{!mno-relax:%{!r:-relax}} \
|
|
%{!shared: \
|
|
%{!static: \
|
|
Index: b/gcc/config/s390/linux.h
|
|
===================================================================
|
|
--- a/gcc/config/s390/linux.h
|
|
+++ b/gcc/config/s390/linux.h
|
|
@@ -65,7 +65,7 @@ along with GCC; see the file COPYING3.
|
|
|
|
#undef LINK_SPEC
|
|
#define LINK_SPEC \
|
|
- "%{m31:-m elf_s390}%{m64:-m elf64_s390} \
|
|
+ "%{m31:-m elf_s390}%{m64:-m elf64_s390} --as-needed \
|
|
%{shared:-shared} \
|
|
%{!shared: \
|
|
%{static:-static} \
|
|
Index: b/gcc/config/rs6000/linux64.h
|
|
===================================================================
|
|
--- a/gcc/config/rs6000/linux64.h
|
|
+++ b/gcc/config/rs6000/linux64.h
|
|
@@ -466,12 +466,12 @@ extern int dot_symbols;
|
|
" -m elf64ppc")
|
|
#endif
|
|
|
|
-#define LINK_OS_LINUX_SPEC32 LINK_OS_LINUX_EMUL32 " %{!shared: %{!static: \
|
|
+#define LINK_OS_LINUX_SPEC32 LINK_OS_LINUX_EMUL32 " --as-needed %{!shared: %{!static: \
|
|
%{rdynamic:-export-dynamic} \
|
|
-dynamic-linker " GNU_USER_DYNAMIC_LINKER32 "}} \
|
|
%(link_os_extra_spec32)"
|
|
|
|
-#define LINK_OS_LINUX_SPEC64 LINK_OS_LINUX_EMUL64 " %{!shared: %{!static: \
|
|
+#define LINK_OS_LINUX_SPEC64 LINK_OS_LINUX_EMUL64 " --as-needed %{!shared: %{!static: \
|
|
%{rdynamic:-export-dynamic} \
|
|
-dynamic-linker " GNU_USER_DYNAMIC_LINKER64 "}} \
|
|
%(link_os_extra_spec64)"
|
|
Index: b/gcc/config/rs6000/sysv4.h
|
|
===================================================================
|
|
--- a/gcc/config/rs6000/sysv4.h
|
|
+++ b/gcc/config/rs6000/sysv4.h
|
|
@@ -784,7 +784,7 @@ ENDIAN_SELECT(" -mbig", " -mlittle", DEF
|
|
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER, UCLIBC_DYNAMIC_LINKER, \
|
|
MUSL_DYNAMIC_LINKER)
|
|
|
|
-#define LINK_OS_LINUX_SPEC "-m elf32ppclinux %{!shared: %{!static: \
|
|
+#define LINK_OS_LINUX_SPEC "-m elf32ppclinux --as-needed %{!shared: %{!static: \
|
|
%{rdynamic:-export-dynamic} \
|
|
-dynamic-linker " GNU_USER_DYNAMIC_LINKER "}}"
|
|
|
|
Index: b/gcc/config/i386/gnu-user64.h
|
|
===================================================================
|
|
--- a/gcc/config/i386/gnu-user64.h
|
|
+++ b/gcc/config/i386/gnu-user64.h
|
|
@@ -57,5 +57,6 @@ see the files COPYING3 and COPYING.RUNTI
|
|
%{" SPEC_32 ":-m " GNU_USER_LINK_EMULATION32 "} \
|
|
%{" SPEC_X32 ":-m " GNU_USER_LINK_EMULATIONX32 "} \
|
|
+ --as-needed \
|
|
%{shared:-shared} \
|
|
%{!shared: \
|
|
%{!static: \
|
|
Index: b/gcc/config/i386/gnu-user.h
|
|
===================================================================
|
|
--- a/gcc/config/i386/gnu-user.h
|
|
+++ b/gcc/config/i386/gnu-user.h
|
|
@@ -74,7 +74,7 @@ along with GCC; see the file COPYING3.
|
|
{ "link_emulation", GNU_USER_LINK_EMULATION },\
|
|
{ "dynamic_linker", GNU_USER_DYNAMIC_LINKER }
|
|
|
|
-#define GNU_USER_TARGET_LINK_SPEC "-m %(link_emulation) %{shared:-shared} \
|
|
+#define GNU_USER_TARGET_LINK_SPEC "-m %(link_emulation) --as-needed %{shared:-shared} \
|
|
%{!shared: \
|
|
%{!static: \
|
|
%{rdynamic:-export-dynamic} \
|
|
Index: b/gcc/config/alpha/linux-elf.h
|
|
===================================================================
|
|
--- a/gcc/config/alpha/linux-elf.h
|
|
+++ b/gcc/config/alpha/linux-elf.h
|
|
@@ -37,7 +37,7 @@ along with GCC; see the file COPYING3.
|
|
|
|
#define ELF_DYNAMIC_LINKER GNU_USER_DYNAMIC_LINKER
|
|
|
|
-#define LINK_SPEC "-m elf64alpha %{G*} %{relax:-relax} \
|
|
+#define LINK_SPEC "-m elf64alpha --as-needed %{G*} %{relax:-relax} \
|
|
%{O*:-O3} %{!O*:-O1} \
|
|
%{shared:-shared} \
|
|
%{!shared: \
|
|
Index: b/gcc/config/arm/linux-elf.h
|
|
===================================================================
|
|
--- a/gcc/config/arm/linux-elf.h
|
|
+++ b/gcc/config/arm/linux-elf.h
|
|
@@ -73,5 +73,6 @@
|
|
%{!shared:-dynamic-linker " GNU_USER_DYNAMIC_LINKER "}} \
|
|
-X \
|
|
+ --as-needed \
|
|
%{mbig-endian:-EB} %{mlittle-endian:-EL}" \
|
|
SUBTARGET_EXTRA_LINK_SPEC
|
|
|
|
Index: b/gcc/config/mips/gnu-user.h
|
|
===================================================================
|
|
--- a/gcc/config/mips/gnu-user.h
|
|
+++ b/gcc/config/mips/gnu-user.h
|
|
@@ -55,6 +55,7 @@ along with GCC; see the file COPYING3.
|
|
#undef GNU_USER_TARGET_LINK_SPEC
|
|
#define GNU_USER_TARGET_LINK_SPEC "\
|
|
%{G*} %{EB} %{EL} %{mips*} %{shared} \
|
|
+ -as-needed \
|
|
%{!shared: \
|
|
%{!static: \
|
|
%{rdynamic:-export-dynamic} \
|
|
Index: b/libjava/Makefile.am
|
|
===================================================================
|
|
--- a/libjava/Makefile.am
|
|
+++ b/libjava/Makefile.am
|
|
@@ -627,14 +631,14 @@
|
|
rm .libs/libgcj_bc.so; \
|
|
mv .libs/libgcj_bc.so.1.0.0 .libs/libgcj_bc.so; \
|
|
$(libgcj_bc_dummy_LINK) -xc /dev/null -Wl,-soname,libgcj_bc.so.1 \
|
|
- -o .libs/libgcj_bc.so.1.0.0 -lgcj || exit; \
|
|
+ -o .libs/libgcj_bc.so.1.0.0 -Wl,--no-as-needed -lgcj || exit; \
|
|
rm .libs/libgcj_bc.so.1; \
|
|
$(LN_S) libgcj_bc.so.1.0.0 .libs/libgcj_bc.so.1
|
|
|
|
## This rule creates the libgcj_bc library that is actually installed.
|
|
install/libgcj_bc.la: $(libgcj_bc_la_OBJECTS) $(libgcj_bc_la_DEPENDENCIES) install/$(am__dirstamp)
|
|
$(libgcj_bc_la_LINK) $(am_libgcj_bc_la_rpath) $(libgcj_bc_la_LDFLAGS) \
|
|
- $(libgcj_bc_la_OBJECTS) $(libgcj_bc_la_LIBADD) $(LIBS)
|
|
+ $(libgcj_bc_la_OBJECTS) $(libgcj_bc_la_LIBADD) $(LIBS) -Wl,--no-as-needed -lgcj
|
|
|
|
## Note that property_files is defined in sources.am.
|
|
propertyo_files = $(patsubst classpath/resource/%,%,$(addsuffix .lo,$(property_files)))
|
|
@@ -762,7 +766,7 @@
|
|
rm $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so; \
|
|
mv $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so.1.0.0 $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so; \
|
|
$(libgcj_bc_dummy_LINK) -xc /dev/null -Wl,-soname,libgcj_bc.so.1 \
|
|
- -o $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so.1.0.0 -lgcj || exit; \
|
|
+ -o $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so.1.0.0 -Wl,--no-as-needed -lgcj || exit; \
|
|
rm $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so.1; \
|
|
$(LN_S) libgcj_bc.so.1.0.0 $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so.1; \
|
|
rm $(DESTDIR)$(toolexeclibdir)/libgcj_bc.la;
|
|
|
|
Index: b/libjava/Makefile.in
|
|
===================================================================
|
|
--- a/libjava/Makefile.in
|
|
+++ b/libjava/Makefile.in
|
|
@@ -10644,13 +10648,13 @@
|
|
rm .libs/libgcj_bc.so; \
|
|
mv .libs/libgcj_bc.so.1.0.0 .libs/libgcj_bc.so; \
|
|
$(libgcj_bc_dummy_LINK) -xc /dev/null -Wl,-soname,libgcj_bc.so.1 \
|
|
- -o .libs/libgcj_bc.so.1.0.0 -lgcj || exit; \
|
|
+ -o .libs/libgcj_bc.so.1.0.0 -Wl,--no-as-needed -lgcj || exit; \
|
|
rm .libs/libgcj_bc.so.1; \
|
|
$(LN_S) libgcj_bc.so.1.0.0 .libs/libgcj_bc.so.1
|
|
|
|
install/libgcj_bc.la: $(libgcj_bc_la_OBJECTS) $(libgcj_bc_la_DEPENDENCIES) install/$(am__dirstamp)
|
|
$(libgcj_bc_la_LINK) $(am_libgcj_bc_la_rpath) $(libgcj_bc_la_LDFLAGS) \
|
|
- $(libgcj_bc_la_OBJECTS) $(libgcj_bc_la_LIBADD) $(LIBS)
|
|
+ $(libgcj_bc_la_OBJECTS) $(libgcj_bc_la_LIBADD) $(LIBS) -Wl,--no-as-needed -lgcj
|
|
|
|
$(propertyo_files): %.lo: classpath/resource/%
|
|
$(mkinstalldirs) `dirname $@`; \
|
|
@@ -12494,7 +12498,7 @@
|
|
@USE_LIBGCJ_BC_TRUE@ rm $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so; \
|
|
@USE_LIBGCJ_BC_TRUE@ mv $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so.1.0.0 $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so; \
|
|
@USE_LIBGCJ_BC_TRUE@ $(libgcj_bc_dummy_LINK) -xc /dev/null -Wl,-soname,libgcj_bc.so.1 \
|
|
-@USE_LIBGCJ_BC_TRUE@ -o $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so.1.0.0 -lgcj || exit; \
|
|
+@USE_LIBGCJ_BC_TRUE@ -o $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so.1.0.0 -Wl,--no-as-needed -lgcj || exit; \
|
|
@USE_LIBGCJ_BC_TRUE@ rm $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so.1; \
|
|
@USE_LIBGCJ_BC_TRUE@ $(LN_S) libgcj_bc.so.1.0.0 $(DESTDIR)$(toolexeclibdir)/libgcj_bc.so.1; \
|
|
@USE_LIBGCJ_BC_TRUE@ rm $(DESTDIR)$(toolexeclibdir)/libgcj_bc.la;
|
|
|