e92c4bdfec
Use the new linux-postmarketos-exynos5 package. A dtb for klimtwifi is added as well, even though the device has not been ported yet. [ci:skip-build]: Already built successfully in MR CI.
120 lines
2.9 KiB
Diff
120 lines
2.9 KiB
Diff
From 757d6e257d04e97f14ffa46779991b7143095f1c Mon Sep 17 00:00:00 2001
|
|
From: Henrik Grimler <henrik@grimler.se>
|
|
Date: Sun, 16 Jan 2022 16:29:43 +0100
|
|
Subject: [PATCH 16/16] ARM: dts: Add support for Samsung Klimt LTE
|
|
|
|
Klimt LTE has the product name Samsung Galaxy Tab S 8.4". Board is
|
|
based on Exynos 5420, and has similar hardware to Klimt WiFi and
|
|
Chagall WiFi.
|
|
|
|
Signed-off-by: Henrik Grimler <henrik@grimler.se>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/exynos5420-klimt-lte.dts | 83 ++++++++++++++++++++++
|
|
2 files changed, 84 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/exynos5420-klimt-lte.dts
|
|
|
|
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
|
index 336b725195d7..863d35173704 100644
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -221,6 +221,7 @@ dtb-$(CONFIG_ARCH_EXYNOS5) += \
|
|
exynos5420-peach-pit.dtb \
|
|
exynos5420-smdk5420.dtb \
|
|
exynos5420-chagall-wifi.dtb \
|
|
+ exynos5420-klimt-lte.dtb \
|
|
exynos5420-klimt-wifi.dtb \
|
|
exynos5422-odroidhc1.dtb \
|
|
exynos5422-odroidxu3.dtb \
|
|
diff --git a/arch/arm/boot/dts/exynos5420-klimt-lte.dts b/arch/arm/boot/dts/exynos5420-klimt-lte.dts
|
|
new file mode 100644
|
|
index 000000000000..2a9af1f18de7
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/exynos5420-klimt-lte.dts
|
|
@@ -0,0 +1,83 @@
|
|
+// SPDX-License-Identifier: GPL-2.0
|
|
+/*
|
|
+ * Samsung's Exynos5420 Klimt LTE board device tree source
|
|
+ *
|
|
+ * Copyright (c) 2012-2013 Samsung Electronics Co., Ltd.
|
|
+ * http://www.samsung.com
|
|
+ * Copyright (c) 2022 Henrik Grimler
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+#include "exynos5420-galaxy-tab-common.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "Samsung Klimt LTE based on Exynos5420";
|
|
+ compatible = "samsung,klimt-lte", "samsung,exynos5420", \
|
|
+ "samsung,exynos5";
|
|
+};
|
|
+
|
|
+&ldo15_reg {
|
|
+ regulator-name = "VDD_LEDA_2V8";
|
|
+ regulator-min-microvolt = <2800000>;
|
|
+ regulator-max-microvolt = <2800000>;
|
|
+
|
|
+ regulator-state-mem {
|
|
+ regulator-on-in-suspend;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ldo17_reg {
|
|
+ regulator-name = "VDD_VCI_3V0";
|
|
+ regulator-min-microvolt = <3000000>;
|
|
+ regulator-max-microvolt = <3000000>;
|
|
+
|
|
+ regulator-state-mem {
|
|
+ regulator-off-in-suspend;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ldo28_reg {
|
|
+ regulator-name = "VDD3_1V8";
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <1800000>;
|
|
+
|
|
+ regulator-state-mem {
|
|
+ regulator-off-in-suspend;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ldo29_reg {
|
|
+ regulator-name = "VDDR_1V6";
|
|
+ regulator-min-microvolt = <1600000>;
|
|
+ regulator-max-microvolt = <1600000>;
|
|
+
|
|
+ regulator-state-mem {
|
|
+ regulator-off-in-suspend;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ldo31_reg {
|
|
+ regulator-name = "VDD_GRIP_1V8";
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <1800000>;
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+
|
|
+ regulator-state-mem {
|
|
+ regulator-off-in-suspend;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ldo32_reg {
|
|
+ regulator-name = "VDD_TSP_1V8";
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <1800000>;
|
|
+
|
|
+ regulator-state-mem {
|
|
+ regulator-off-in-suspend;
|
|
+ };
|
|
+};
|
|
+
|
|
+&mmc_2 {
|
|
+ sd-uhs-sdr104;
|
|
+};
|
|
--
|
|
2.34.1
|
|
|