e92c4bdfec
Use the new linux-postmarketos-exynos5 package. A dtb for klimtwifi is added as well, even though the device has not been ported yet. [ci:skip-build]: Already built successfully in MR CI.
111 lines
2.8 KiB
Diff
111 lines
2.8 KiB
Diff
From 2c8a691d2a52b047ab21aab3ba3764ba224210ed Mon Sep 17 00:00:00 2001
|
|
From: Henrik Grimler <henrik@grimler.se>
|
|
Date: Wed, 31 Mar 2021 21:45:11 +0200
|
|
Subject: [PATCH 14/16] ARM: dts: Add support for Samsung Klimt WiFi
|
|
|
|
Klimt WiFi has the product name Samsung Galaxy Tab S 8.4". Board is
|
|
based on Exynos 5420, and has similar hardware to Chagall WiFi.
|
|
|
|
Signed-off-by: Henrik Grimler <henrik@grimler.se>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/exynos5420-klimt-wifi.dts | 75 +++++++++++++++++++++
|
|
2 files changed, 76 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/exynos5420-klimt-wifi.dts
|
|
|
|
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
|
index 088fcedb3212..336b725195d7 100644
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -221,6 +221,7 @@ dtb-$(CONFIG_ARCH_EXYNOS5) += \
|
|
exynos5420-peach-pit.dtb \
|
|
exynos5420-smdk5420.dtb \
|
|
exynos5420-chagall-wifi.dtb \
|
|
+ exynos5420-klimt-wifi.dtb \
|
|
exynos5422-odroidhc1.dtb \
|
|
exynos5422-odroidxu3.dtb \
|
|
exynos5422-odroidxu3-lite.dtb \
|
|
diff --git a/arch/arm/boot/dts/exynos5420-klimt-wifi.dts b/arch/arm/boot/dts/exynos5420-klimt-wifi.dts
|
|
new file mode 100644
|
|
index 000000000000..7c3ba5abd7bf
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/exynos5420-klimt-wifi.dts
|
|
@@ -0,0 +1,75 @@
|
|
+// SPDX-License-Identifier: GPL-2.0
|
|
+/*
|
|
+ * Samsung's Exynos5420 Klimt WiFi board device tree source
|
|
+ *
|
|
+ * Copyright (c) 2012-2013 Samsung Electronics Co., Ltd.
|
|
+ * http://www.samsung.com
|
|
+ * Copyright (c) 2022 Henrik Grimler
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+#include "exynos5420-galaxy-tab-common.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "Samsung Klimt WiFi based on Exynos5420";
|
|
+ compatible = "samsung,klimt-wifi", "samsung,exynos5420", \
|
|
+ "samsung,exynos5";
|
|
+};
|
|
+
|
|
+&ldo15_reg {
|
|
+ /* Unused */
|
|
+ regulator-name = "VDD_LDO15";
|
|
+ regulator-min-microvolt = <2800000>;
|
|
+ regulator-max-microvolt = <2800000>;
|
|
+};
|
|
+
|
|
+&ldo17_reg {
|
|
+ regulator-name = "VDD_VCI_3V0";
|
|
+ regulator-min-microvolt = <3000000>;
|
|
+ regulator-max-microvolt = <3000000>;
|
|
+
|
|
+ regulator-state-mem {
|
|
+ regulator-off-in-suspend;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ldo28_reg {
|
|
+ regulator-name = "VDD3_1V8";
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <1800000>;
|
|
+
|
|
+ regulator-state-mem {
|
|
+ regulator-off-in-suspend;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ldo29_reg {
|
|
+ regulator-name = "VDDR_1V6";
|
|
+ regulator-min-microvolt = <1600000>;
|
|
+ regulator-max-microvolt = <1600000>;
|
|
+
|
|
+ regulator-state-mem {
|
|
+ regulator-off-in-suspend;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ldo31_reg {
|
|
+ /* Unused */
|
|
+ regulator-name = "VDD_LDO31";
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <1800000>;
|
|
+};
|
|
+
|
|
+&ldo32_reg {
|
|
+ regulator-name = "VDD_TSP_1V8";
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <1800000>;
|
|
+
|
|
+ regulator-state-mem {
|
|
+ regulator-off-in-suspend;
|
|
+ };
|
|
+};
|
|
+
|
|
+&mmc_2 {
|
|
+ sd-uhs-sdr104;
|
|
+};
|
|
--
|
|
2.34.1
|
|
|