bde7c3b90b
Use latest sources from LineageOS, instead of the ones from andip71.
The APKBUILD is modernized to use the devicepkg-dev but unfortunately
compiling with gcc8 it doesn't boot.
The kernel config is updated with the required options to start the
lxc-android container and xf86-video-hwcomposer works
(tested with xfce4).
My plan was to add the firmware-samsung-klte with the subpackages for
the wifi blobs and a precompiled android system.img to use with
libhybris, but my device just died and I'm not able to power it on (I've
probably burnt the Power IC 😢)
40 lines
1.5 KiB
Diff
40 lines
1.5 KiB
Diff
From b7756b6fc4bb728722b14d2dfdbaf1dc843812e9 Mon Sep 17 00:00:00 2001
|
|
From: Chet Kener <Cl3Kener@gmail.com>
|
|
Date: Tue, 21 Oct 2014 18:41:36 -0400
|
|
Subject: [PATCH] gpu:msm: Fix 5.0 compile
|
|
|
|
* These need to be static to avoid these errors:
|
|
|
|
drivers/built-in.o: In function `.LANCHOR1':
|
|
msm_iommu_sec.c:(.data+0x9298): undefined reference to `kgsl_iommu_sync_lock'
|
|
msm_iommu_sec.c:(.data+0x929c): undefined reference to `kgsl_iommu_sync_unlock'
|
|
Makefile:877: recipe for target '.tmp_vmlinux1' failed
|
|
make: *** [.tmp_vmlinux1] Error 1
|
|
|
|
Signed-off-by: Chet Kener <Cl3Kener@gmail.com>
|
|
---
|
|
drivers/gpu/msm/kgsl_iommu.c | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/drivers/gpu/msm/kgsl_iommu.c b/drivers/gpu/msm/kgsl_iommu.c
|
|
index c4fa8af4..4f66a2f0 100644
|
|
--- a/drivers/gpu/msm/kgsl_iommu.c
|
|
+++ b/drivers/gpu/msm/kgsl_iommu.c
|
|
@@ -1002,7 +1002,7 @@ static int kgsl_iommu_init_sync_lock(struct kgsl_mmu *mmu)
|
|
*
|
|
* Return - int - number of commands.
|
|
*/
|
|
-inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
|
+static inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
|
unsigned int *cmds)
|
|
{
|
|
struct kgsl_device *device = mmu->device;
|
|
@@ -1072,7 +1072,7 @@ inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
|
*
|
|
* Return - int - number of commands.
|
|
*/
|
|
-inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
|
+static inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
|
unsigned int *cmds)
|
|
{
|
|
struct kgsl_device *device = mmu->device;
|