aa1eefc44a
These are various debugging related patches that I have used over the time when attempting to get new features working for the mainline kernel. Given that the downstream kernel is just intended for debugging in this case, it seems convenient to add them to pmaports so I don't need to go search for them in case I need them again in the future. [ci:skip-build] Already built on CI
27 lines
877 B
Diff
27 lines
877 B
Diff
gcc-wrapper.py is stupid, slow and requires Python 2. Basically it's just
|
|
supposed to make the build fail on certain hardcoded compile warnings.
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 4994d640e19..ad01b820543 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -326,7 +326,7 @@ include $(srctree)/scripts/Kbuild.include
|
|
|
|
AS = $(CROSS_COMPILE)as
|
|
LD = $(CROSS_COMPILE)ld
|
|
-REAL_CC = $(CROSS_COMPILE)gcc
|
|
+CC = $(CROSS_COMPILE)gcc
|
|
CPP = $(CC) -E
|
|
AR = $(CROSS_COMPILE)ar
|
|
NM = $(CROSS_COMPILE)nm
|
|
@@ -340,10 +340,6 @@ DEPMOD = /sbin/depmod
|
|
PERL = perl
|
|
CHECK = sparse
|
|
|
|
-# Use the wrapper for the compiler. This wrapper scans for new
|
|
-# warnings and causes the build to stop upon encountering them.
|
|
-CC = $(srctree)/scripts/gcc-wrapper.py $(REAL_CC)
|
|
-
|
|
CHECKFLAGS := -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ \
|
|
-Wbitwise -Wno-return-void $(CF)
|
|
CFLAGS_MODULE =
|