b402c03b1f
This upgrade has no effect on postmarketOS, as there were only systemd service files added to the repository. The upgrade is done solely to keep track with the newest version. [ci:skip-build] already built successfully in CI
26 lines
792 B
Text
26 lines
792 B
Text
# Maintainer: Jakko <jahau@rocketmail.com>
|
|
pkgname=swclock-offset
|
|
pkgver=0.2.2
|
|
pkgrel=0
|
|
pkgdesc="Keep system time at an offset to a non-writable RTC"
|
|
url="https://gitlab.com/postmarketOS/swclock-offset"
|
|
arch="noarch"
|
|
license="GPL-3.0-or-later"
|
|
install="$pkgname.post-deinstall"
|
|
subpackages="$pkgname-openrc"
|
|
source="https://gitlab.com/postmarketOS/swclock-offset/-/archive/$pkgver/swclock-offset-$pkgver.tar.gz"
|
|
options="!check" # No tests
|
|
|
|
package() {
|
|
make DESTDIR="$pkgdir" install
|
|
make DESTDIR="$pkgdir" install_openrc
|
|
}
|
|
|
|
openrc() {
|
|
install="$subpkgname.post-install $subpkgname.pre-deinstall"
|
|
default_openrc
|
|
}
|
|
|
|
sha512sums="
|
|
44f759dd2249ecce35f5baf9f432fd933e3a07b7ea425ea0f07314c7c3c94ce2d1ab7442d9bce8f03f5d436d15865ae3f4f63d3dc83cc6063af09986b7767e10 swclock-offset-0.2.2.tar.gz
|
|
"
|