a85db1dc7b
At the moment we have Contributor: lines on some packages (but not all of them), but often they don't represent the actual contributors to the package very well. E.g. when we added them retroactively to the device packages we only added the initial contributor (which isn't necessarily the person who made most of the work for a device...) The Git history is the most representative source for figuring out who contributed to a package, so there is no reason to duplicate that into the APKBUILD. [skip ci]: way too many packages
23 lines
707 B
Text
23 lines
707 B
Text
# Maintainer: Daniele Debernardi <drebrez@gmail.com>
|
|
pkgname=reboot-mode
|
|
pkgver=1.0.0
|
|
pkgrel=0
|
|
pkgdesc="Reboot the device to a specific mode"
|
|
url="https://postmarketos.org"
|
|
arch="all"
|
|
license="GPL-3.0-or-later"
|
|
makedepends="musl-dev linux-headers"
|
|
source="https://gitlab.com/postmarketos/reboot-mode/-/archive/$pkgver/reboot-mode-$pkgver.tar.gz"
|
|
options="!check" # No tests
|
|
|
|
build() {
|
|
gcc reboot-mode.c -o reboot-mode.o -c
|
|
gcc reboot-mode.o -o reboot-mode
|
|
}
|
|
|
|
package() {
|
|
install -Dm755 reboot-mode \
|
|
"$pkgdir"/usr/sbin/reboot-mode
|
|
}
|
|
|
|
sha512sums="926fae6f1b78b144f092d291f1d0edf58f2a5ea98d3af7aa812f4f1e1330002feb5a8c4499fe334e6d22bc515467359a5a0651e3995d2217a844f3c1b668ae9b reboot-mode-1.0.0.tar.gz"
|