pmaports/main/postmarketos-bootsplash/APKBUILD
Clayton Craft fe20c109fc
main/postmarketos-bootsplash: fix kill-pbsplash systemd service (MR 5286)
This wasn't actually getting run on boot because After=graphical.target
created an ordering issue and systemd was disabling it.

I saw this ordering issue in the journal after finding that pbsplash was
still running in the background after the UI loaded, and confirmed it by
running systemd-analyze.
2024-06-27 19:17:38 +02:00

73 lines
3.5 KiB
Text

# Maintainer: Caleb Connolly <caleb@connolly.tech>
pkgname=postmarketos-bootsplash
pkgver=0.2.3
pkgrel=0
pkgdesc="pmOS integration components for pbsplash"
url="https://postmarketos.org"
arch="all"
license="CC-BY-SA-3.0"
depends="devicepkg-utils pbsplash"
options="!check" # no testsuite
subpackages="$pkgname-openrc $pkgname-systemd"
source="
kill-pbsplash
kill-pbsplash.service
shutdown-splash.service
kill-pbsplash-override.conf
99-shutdown-pbsplash.stop
OpenSans-Regular.svg
pmos-logo.svg
pmos-logo-text.svg
pmos-logo-text-epaper.svg
postmarketos-bootsplash.files
"
package() {
install -Dm755 "$srcdir/kill-pbsplash" -t "$pkgdir"/etc/init.d/
install -Dm755 "$srcdir/99-shutdown-pbsplash.stop" -t "$pkgdir"/etc/local.d/
install -Dm644 "$srcdir"/OpenSans-Regular.svg -t "$pkgdir"/usr/share/pbsplash/
install -Dm644 "$srcdir"/pmos-logo.svg -t "$pkgdir"/usr/share/pbsplash/
install -Dm644 "$srcdir"/pmos-logo-text.svg -t "$pkgdir"/usr/share/pbsplash/
install -Dm644 "$srcdir"/pmos-logo-text-epaper.svg -t "$pkgdir"/usr/share/pbsplash/
install -Dm644 "$srcdir"/postmarketos-bootsplash.files \
"$pkgdir"/usr/share/mkinitfs/files/30-postmarketos-bootsplash.files
}
openrc() {
install="$subpkgname.post-install"
default_openrc
}
systemd() {
install_if="$pkgname=$pkgver-r$pkgrel systemd"
install -Dm644 "$srcdir/kill-pbsplash.service" -t \
"$subpkgdir"/usr/lib/systemd/system/
mkdir -p "$subpkgdir"/usr/lib/systemd/system/multi-user.target.wants
ln -s ../kill-pbsplash.service \
"$subpkgdir"/usr/lib/systemd/system/multi-user.target.wants/
install -Dm644 "$srcdir/kill-pbsplash-override.conf" -t \
"$subpkgdir"/usr/lib/systemd/system/display-manager.service.d/
install -Dm644 "$srcdir/shutdown-splash.service" \
-t "$subpkgdir"/usr/lib/systemd/system/
# Install into related targets
for target in halt reboot shutdown; do
mkdir -p "$subpkgdir"/usr/lib/systemd/system/"$target".target.wants
ln -s ../shutdown-splash.service \
"$subpkgdir"/usr/lib/systemd/system/"$target".target.wants/
done
}
sha512sums="
7e5416f0f9de3605dcbc5ddd4b93d244fd6d4fd1bc2d5a15a034263f8517fc51e73509f29f2a13397d059913917990ada89b36ac7b00a0d21c0283fade755c1c kill-pbsplash
79dd5eacf5914fb5eb1ef1b820478c07d2e0ae49441c9dc32c2ec18f26303f0e97c85221bab8e79abb854949e1ac4c20c566bb16379d4d396bda10d3d3b3d4d1 kill-pbsplash.service
476c7a8106429c35e772eaf98e257f7a77070050431875113c7c0c75a358250757a381086c7302f1eded0d4cde88d2e63f9fa5d69b6fce46e2d908afd8d9323a shutdown-splash.service
c413607e21c805fff3d9948963aebf1048cdb2e68ed2f4316723d21f861a32aede7d1bf3851c8ba7562b07302471ca6d8f7be1e0487d83dd4cdea9bbb506e792 kill-pbsplash-override.conf
3b862e2282c79d6ffc7aa8dc3992562c11fea5633c98e3ff9c6205a907f5d995e9fcf098adcf294e0648436df97746a3943b9b761ddf72339cc5589fb8904a8d 99-shutdown-pbsplash.stop
2387c64d84f0ba3ee76925f55c87ce025140aa3cd462107a851c34ffd89bd52f606e0d1f9f371d4f642d96545d5cc1bc0fcfb23ca7629a9149055f068da6bffd OpenSans-Regular.svg
98984fd67b99400d2b08422c4d314da558d3c94ee67dbc895e7bbfd6fdf22d4b2c9d35f48f4b73b383a054f535d4089fb705c5532f034cb2ee54eab2184e8e86 pmos-logo.svg
1940480fb98ffd1cef17c0ed440d44aa200119d022ce59973a18fa39ee040b19e748312ae61edae4ff8d2bacf42b4d7c9144274b99cd8563e4a106447825b8f2 pmos-logo-text.svg
d673bacfcf16cdaa602e82663ffc17e131040e76e4ebd4078f8340c4ebb5be983ac8a4c9acf25f7c8b725a36adb7e775cbeef1b3cc809f58d876e70994b8f6c2 pmos-logo-text-epaper.svg
bdef8c991bc8caff2788433fdc399a36541833f373b2db236d55419ccce34993a6b897ec7c27f27b16facadf2699aa189c6c867f233bb38d778ffb6e67efc090 postmarketos-bootsplash.files
"