c9bab638d4
Latest release of "old" lk2nd. Release notes: - msm8974 improvements - New variants for few Samsung devices, some renames - Added Lenovo Vibe K5 variants New devices: - Vivo Y21L - Motorola Moto G 4G - Huawei G7 Plus - Samsung Galaxy On7 2015 (SM-G600FY) - HTC One M8 - Samsung G360T Added big patch to fix compile errors with gcc-14. Signed-off-by: Alexey Minnekhanov <alexeymin@postmarketos.org> [ci:skip-build]: already built successfully in CI
111 lines
3.2 KiB
Text
111 lines
3.2 KiB
Text
# Maintainer: Alexey Minnekhanov <alexeymin@postmarketos.org>
|
|
pkgname=lk2nd
|
|
pkgver=0.16.0
|
|
pkgrel=0
|
|
pkgdesc="Secondary little kernel (lk) bootloader for several Qualcomm devices"
|
|
arch="armv7 aarch64"
|
|
url="https://github.com/msm8916-mainline/lk2nd"
|
|
license="MIT AND BSD-3-Clause AND GPL-2.0-only"
|
|
makedepends="dtc dtc-dev gcc-arm-none-eabi python3 py3-libfdt"
|
|
source="
|
|
$pkgname-$pkgver.tar.gz::https://github.com/msm8916-mainline/lk2nd/archive/refs/tags/$pkgver.tar.gz
|
|
0001-build-fixes.patch
|
|
"
|
|
options="!check !archcheck !tracedeps !strip pmb:cross-native"
|
|
# This APKBUILD builds bare metal executable; options are very specific!
|
|
# * there are no tests (how do you even test the bootloader?);
|
|
# * binaries are "arch-independent"; aarch64 build also produces armv7 binary,
|
|
# because ARM CPUs boot in 32-bit mode;
|
|
# * there are no depends for bootloader, it's a kernel and OS in one binary;
|
|
# * stripping of unused sections is done in lk2nd's own ld script.
|
|
|
|
subpackages="
|
|
$pkgname-msm8916
|
|
$pkgname-msm8916-appended:msm8916_appended
|
|
"
|
|
|
|
if [ "$CARCH" = "armv7" ]; then
|
|
subpackages="
|
|
$subpackages
|
|
$pkgname-msm8226
|
|
$pkgname-msm8226-appended:msm8226_appended
|
|
$pkgname-msm8226-htc-memul:msm8226_htc_memul
|
|
$pkgname-msm8974
|
|
$pkgname-msm8974-appended:msm8974_appended
|
|
"
|
|
fi
|
|
|
|
_build() {
|
|
# This builds baremetal executable; distro-specific compiler flags
|
|
# and optimizations can't be set by build system.
|
|
unset CFLAGS
|
|
unset CXXFLAGS
|
|
unset CPPFLAGS
|
|
unset LDFLAGS
|
|
unset CROSS_COMPILE
|
|
unset CC
|
|
unset CXX
|
|
|
|
# ccache and crossdirect "gcc"s are in PATH, get rid of them too,
|
|
# redefine PATH to be bare minimum
|
|
unset PATH
|
|
export PATH=/usr/sbin:/usr/bin:/sbin:/bin
|
|
|
|
local project="$1"; shift
|
|
|
|
make LK2ND_VERSION="$pkgver-r$pkgrel-postmarketos" TOOLCHAIN_PREFIX=arm-none-eabi- "$@" "$project"
|
|
}
|
|
|
|
build() {
|
|
_build lk2nd-msm8916
|
|
if [ "$CARCH" = "armv7" ]; then
|
|
_build lk2nd-msm8974
|
|
_build lk2nd-msm8226
|
|
_build lk2nd-msm8226 BOOTLOADER_OUT=htc-memul SCRATCH_ADDR=0x20000000 SCRATCH_ADDR_512MAP=0x20000000 SCRATCH_SIZE_512MAP=0x10000000
|
|
fi
|
|
}
|
|
|
|
package() {
|
|
# main package is empty
|
|
mkdir -p "$pkgdir"
|
|
}
|
|
|
|
msm8916() {
|
|
install -Dm644 "$builddir"/build-lk2nd-msm8916/lk2nd.img -t \
|
|
"$subpkgdir"/boot
|
|
}
|
|
|
|
msm8916_appended() {
|
|
install -Dm644 "$builddir"/build-lk2nd-msm8916/lk2nd-appended-dtb.img \
|
|
"$subpkgdir"/boot/lk2nd.img
|
|
}
|
|
|
|
msm8974() {
|
|
install -Dm644 "$builddir"/build-lk2nd-msm8974/lk2nd.img -t \
|
|
"$subpkgdir"/boot
|
|
}
|
|
|
|
msm8974_appended() {
|
|
install -Dm644 "$builddir"/build-lk2nd-msm8974/lk2nd-appended-dtb.img \
|
|
"$subpkgdir"/boot/lk2nd.img
|
|
}
|
|
|
|
msm8226() {
|
|
install -Dm644 "$builddir"/build-lk2nd-msm8226/lk2nd.img \
|
|
"$subpkgdir"/boot/lk2nd.img
|
|
}
|
|
|
|
msm8226_appended() {
|
|
install -Dm644 "$builddir"/build-lk2nd-msm8226/lk2nd-appended-dtb.img \
|
|
"$subpkgdir"/boot/lk2nd.img
|
|
}
|
|
|
|
msm8226_htc_memul() {
|
|
install -Dm644 "$builddir"/htc-memul/build-lk2nd-msm8226/lk2nd.img \
|
|
"$subpkgdir"/boot/lk2nd.img
|
|
}
|
|
|
|
sha512sums="
|
|
e3708b02f7bf677c60b9f09e75d70c05438466c62378294b31109c9085bfaf5e25598c91a841dc2756367b5cb069e10d9df56c1d1b174ba07b8fd2017487c5c2 lk2nd-0.16.0.tar.gz
|
|
e0ff876f69950cd3026d0168edc7e32d1f671a448153ee3c1dcf8906aed3c67b91bdd3e1ea73e789c7d85fbf2bebd42054dd89ae486d1921df456f606a7e82d2 0001-build-fixes.patch
|
|
"
|