pmaports/main/boot-deploy/APKBUILD
Clayton Craft 5252ae1f32
main/boot-deploy: upgrade to 0.17
Features:

   - Add support for prepending DHTB to boot.img (MR 67) <19atlas>
   - Add support for generating compressed depthcharge images (MR 65) <WeirdTreeThing>

Fixes:

   - Flash android boot image with fastboot-bootpart if not EFI booting (MR 68) <Caleb Connolly>

Other:

   - Improve contributing documentation (MR 62) <Clayton Craft>
2024-07-26 22:16:20 +02:00

32 lines
1.1 KiB
Text

# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname=boot-deploy
pkgver=0.17
pkgrel=0
pkgdesc="tool for finalizing and deploying boot related files"
url="https://gitlab.com/postmarketos/boot-deploy"
arch="noarch"
license="GPL-2.0-or-later"
source="
os-customization
https://gitlab.com/postmarketOS/boot-deploy/-/archive/$pkgver/boot-deploy-$pkgver.tar.gz
"
check() {
./test_boot_deploy_functions.sh
}
package() {
install -Dm755 boot-deploy "$pkgdir"/sbin/boot-deploy
install -Dm755 boot-deploy-functions.sh \
"$pkgdir"/usr/share/boot-deploy/boot-deploy-functions.sh
install -Dm644 "$srcdir"/os-customization \
"$pkgdir"/usr/share/boot-deploy/os-customization
touch boot-deploy-trigger
install -Dm644 boot-deploy-trigger \
"$pkgdir"/usr/share/mkinitfs-triggers/boot-deploy
}
sha512sums="
a243975b9850d9933e0f917f7eb38fc4a76ea658c3dcc56f035f60ee6c62d6740c1107143b8210bdc0231d4c9b6b2003e458120985604eb09649322d359ae89f os-customization
db77ffa700087d60d3ff0a8708c4ca68234eaa019ff7ea5f2c2c4035c77c20b325bd9ce22d155213d2b38766ff31fd82ca51b8f66067b6dda072a425b978162c boot-deploy-0.17.tar.gz
"