pmaports/device/testing/linux-lg-d802/APKBUILD
Clayton Craft d164248ac6
linux-*: bump pkgrel for kernels that use downstreamkernel_package (MR 2426)
This function was changed, so these packages need to be rebuilt to have
the kernel installed under the new filename 'vmlinuz'
2021-09-03 10:29:07 -07:00

59 lines
2.4 KiB
Text

# Reference: <https://postmarketos.org/vendorkernel>
# Kernel config based on: arch/arm/configs/lineageos_d802_defconfig
pkgname=linux-lg-d802
pkgver=3.4.113
pkgrel=2
pkgdesc="LG G2 kernel fork"
arch="armv7"
_carch="arm"
_flavor="lg-d802"
url="https://kernel.org"
license="GPL-2.0-only"
options="!strip !check !tracedeps pmb:cross-native"
makedepends="bash bc bison devicepkg-dev flex openssl-dev perl dtbtool xz"
# Source
_repository="android_kernel_lge_msm8974"
_commit="b308bede8bcb1f307a7f42e38a24aae92b2f5edd"
_config="config-$_flavor.$arch"
source="
$pkgname-$_commit.tar.gz::https://github.com/LineageOS/$_repository/archive/$_commit.tar.gz
$_config
gcc7-give-up-on-ilog2-const-optimizations.patch
gcc8-fix-put-user.patch
gcc10-extern_YYLOC_global_declaration.patch
kernel-use-the-gnu89-standard-explicitly.patch
"
builddir="$srcdir/$_repository-$_commit"
_outdir="out"
prepare() {
default_prepare
. downstreamkernel_prepare
}
build() {
unset LDFLAGS
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
# Master DTB (deviceinfo_bootimg_qcdt)
dtbTool -p scripts/dtc/ -o "$_outdir/arch/$_carch/boot"/dt.img \
"$_outdir/arch/$_carch/boot/"
}
package() {
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
install -Dm644 "$_outdir/arch/$_carch/boot"/dt.img \
"$pkgdir"/boot/dt.img
}
sha512sums="
358e4f2fa9e97ed80def3d623f8773dd9cd7dac5dec0df5ad65a2dab51a3cb5e3615f4c373075ce752e244422a8fcf5c2f3d6980552bf63c36afba247edec346 linux-lg-d802-b308bede8bcb1f307a7f42e38a24aae92b2f5edd.tar.gz
a334a3c4001c9215cda470c9fef7fff6cc80012e6781432dfea60444b669a585724a3c6b41b97799b061b54687e83b7f2ce6e14bf65fb1eebf27b502c6af3606 config-lg-d802.armv7
77eba606a71eafb36c32e9c5fe5e77f5e4746caac292440d9fb720763d766074a964db1c12bc76fe583c5d1a5c864219c59941f5e53adad182dbc70bf2bc14a7 gcc7-give-up-on-ilog2-const-optimizations.patch
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
ad0182a483791fc88e058838bc331b2f04a75ba291e763767babdb815efadfc3b4fda97e69e2e3f00a426cabea088e35297a92bd287592597d1e309be68ee92c kernel-use-the-gnu89-standard-explicitly.patch
"