pmaports/device/testing/firmware-t2m-flame/APKBUILD
Johannes Marbach 95d375879c
treewide: firmware: use pmb:cross-native/!tracdeps (MR 2468)
Add pmb:cross-native/!tracedeps to applicable firmware packages and
secure both with a test.

This sets the pmb:cross-native and !tracedeps options on all firmware-*
packages that are compatible with the native compilation method. A unit
test ensures the presence of both options while maintaining a list of
exempted packages.

Fixes: #718
[ci:ignore-count] [ci:skip-vercheck] [ci:skip-build]
2021-09-19 18:57:36 +02:00

19 lines
761 B
Text

pkgname=firmware-t2m-flame
pkgver=1
pkgrel=5
_commit="503a4052a8bfdc3b4c06533f2d08fe4d6a923842"
pkgdesc="Mozilla Flame Firmware"
url="https://github.com/yuvadm/mozilla-flame-firmware"
arch="armhf"
license="proprietary"
source="$pkgname-$_commit.tar.gz::https://github.com/yuvadm/mozilla-flame-firmware/archive/$_commit.tar.gz"
options="!check !strip !archcheck !spdx !tracedeps pmb:cross-native"
builddir="$srcdir/mozilla-flame-firmware-$_commit"
package() {
for _i in *; do
install -Dm644 "$_i" "$pkgdir"/lib/firmware/postmarketos/"$_i"
done
}
sha512sums="865c6cb88d44c5305b088db4d244f9e178f2ddd7550c481aadeb6444fd853e004641b8900172ec326a11037aa170a658d32d9e62d0780ee50838e89983178384 firmware-t2m-flame-503a4052a8bfdc3b4c06533f2d08fe4d6a923842.tar.gz"