6157a01f0f
Some firmware packages has only a WCNSS config file, which is decoded from base64 uploaded to Pastebin, and there is nothing to unpack. [ci:ignore-count] [ci:skip-build]: already built successfully in CI
31 lines
899 B
Text
31 lines
899 B
Text
pkgname=firmware-samsung-on7
|
|
pkgver=1
|
|
pkgrel=1
|
|
_name="Samsung Galaxy On7 (2015)"
|
|
pkgdesc="Firmware for $_name"
|
|
url="https://postmarketos.org"
|
|
subpackages="$pkgname-wcnss-nv:wcnss_nv"
|
|
arch="aarch64"
|
|
license="proprietary"
|
|
options="!check !strip !archcheck !tracedeps pmb:cross-native"
|
|
source="$pkgname-WCNSS_qcom_wlan_nv.bin.base64::https://pastebin.com/raw/4c9b2b94"
|
|
|
|
_fwdir="/lib/firmware/postmarketos"
|
|
|
|
build() {
|
|
base64 -d $pkgname-WCNSS_qcom_wlan_nv.bin.base64 > WCNSS_qcom_wlan_nv.bin
|
|
}
|
|
|
|
package() {
|
|
# parent package is empty
|
|
mkdir -p "$pkgdir"
|
|
}
|
|
|
|
wcnss_nv() {
|
|
pkgdesc="$_name WiFi/BT firmware configuration"
|
|
install -Dm644 "$srcdir"/WCNSS_qcom_wlan_nv.bin -t "$subpkgdir/$_fwdir"/wlan/prima
|
|
}
|
|
|
|
sha512sums="
|
|
804aeab6ba94c6a0bf44f2b9681b6ed3609df529f3f2a2b645dfd543c152997a2527044028c743e2767671819300ee7779ffa9eed7e17e359889e1af0a030987 firmware-samsung-on7-WCNSS_qcom_wlan_nv.bin.base64
|
|
"
|