c06adf0310
Remove a530 firmware files in favor of firmware-qcom-adreno-a530.
33 lines
1.3 KiB
Text
33 lines
1.3 KiB
Text
# Maintainer: Sireesh Kodali <scarface@disroot.org>
|
|
pkgname=firmware-motorola-potter
|
|
pkgver=2
|
|
pkgrel=1
|
|
pkgdesc="Firmware for Motorola Moto G5 Plus"
|
|
url="https://github.com/scarface-one/firmware-motorola-potter"
|
|
arch="aarch64"
|
|
license="proprietary"
|
|
options="!check !strip !archcheck !tracedeps"
|
|
_commit="cce83e64585c036facd4cef39f47bc23d18ba2e9"
|
|
builddir="$srcdir/$pkgname-$_commit/lib/firmware/postmarketos"
|
|
install="$pkgname.post-install $pkgname.post-upgrade"
|
|
_fwdir="/lib/firmware/postmarketos"
|
|
|
|
source="
|
|
$pkgname-$_commit.tar.gz::$url/archive/$_commit.tar.gz
|
|
moto-modem-rfs-setup.openrc
|
|
"
|
|
|
|
package() {
|
|
install -Dm755 $srcdir/moto-modem-rfs-setup.openrc "$pkgdir"/etc/init.d/moto-modem-rfs-setup
|
|
|
|
# GPU Firmware files
|
|
install -Dm644 a506_zap.b02 -t "$pkgdir/$_fwdir"
|
|
install -Dm644 a506_zap.mdt -t "$pkgdir/$_fwdir"
|
|
|
|
# WLAN Firmware
|
|
install -Dm644 wlan/prima/WCNSS_qcom_wlan_nv.bin -t "$pkgdir/$_fwdir/wlan/prima"
|
|
}
|
|
sha512sums="
|
|
5a35ff1b567b672585f761eddbc772163f52b312c1e94410eff4b1d333852857a2f87769a45f47f7bcff373bdd5b062c3d16110e0211d85f83a7b4c6c78f6d3c firmware-motorola-potter-cce83e64585c036facd4cef39f47bc23d18ba2e9.tar.gz
|
|
d4fd0f3406c9f004e9cae7bc500c5713aab75f102f8e3ea1af820865f01eb03def01cd9ed3e8a184c7dfc22ab419628fad17957a3782885d96eb36e94461e842 moto-modem-rfs-setup.openrc
|
|
"
|