3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
33 lines
817 B
Text
33 lines
817 B
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
# Maintainer: Doni Halim <donihaalim@gmail.com>
|
|
pkgname=device-zte-b860hv5
|
|
pkgdesc="ZTE ZXV10 B860HV5"
|
|
pkgver=0.1
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="
|
|
postmarketos-base
|
|
linux-postmarketos-amlogic
|
|
u-boot-amlogic-s905x2-tv
|
|
"
|
|
makedepends="devicepkg-dev"
|
|
source="
|
|
deviceinfo
|
|
modules-initfs
|
|
"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
sha512sums="
|
|
c1d8a2047649cb745cb12226f1ce19cfeb6926a06d9f257446cd84600a1fbdb1fec3acb100502119cf95e0c0bf37a41756a41149406bf42fb76ef4b510da5ae0 deviceinfo
|
|
cbd7012fcb2db0f11f694ffa621e4c47447f6b36690366da35a16918b20e58a0324cfd07eb3ed7165887e099100286098d19ae131bd62ac8b3a088780f59a1d8 modules-initfs
|
|
"
|