3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
45 lines
1,022 B
Text
45 lines
1,022 B
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-sourceparts-pocketpc
|
|
pkgdesc="Source Parts Pocket P.C."
|
|
pkgver=1
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="
|
|
linux-sourceparts-pocketpc
|
|
postmarketos-base
|
|
u-boot-sourceparts-pocketpc
|
|
u-boot-tools
|
|
"
|
|
makedepends="devicepkg-dev"
|
|
source="
|
|
deviceinfo
|
|
uboot-script.cmd
|
|
"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
mkimage \
|
|
-A arm \
|
|
-O linux \
|
|
-T script \
|
|
-C none \
|
|
-a 0 \
|
|
-e 0 \
|
|
-n postmarketos \
|
|
-d "$srcdir"/uboot-script.cmd \
|
|
"$srcdir"/boot.scr
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
install -Dm644 "$srcdir"/boot.scr \
|
|
"$pkgdir"/boot/boot.scr
|
|
}
|
|
|
|
sha512sums="
|
|
69d6d0f8daf09403cd59a46873db575616ca9c7c5d2571a2e6aa975d26cc7777f47f51201003d197f3df32f41e076be64a4f4559db5c6bd234a4dfd6dfc9a169 deviceinfo
|
|
fef3c97c335eed2636f94cf2a207f7225b89bf00c159744897f41e900d7f9c8df5fc66964c2bc04726a4a5397da2b414377eeccfb4a2e6a6f0361156140357d4 uboot-script.cmd
|
|
"
|