pmaports/device/testing/device-samsung-on7/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

42 lines
1.1 KiB
Text

# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-samsung-on7
pkgdesc="Samsung Galaxy On7 (2015)"
pkgver=1
pkgrel=1
url="https://postmarketos.org"
license="MIT"
arch="aarch64"
options="!check !archcheck"
depends="
postmarketos-base
mkbootimg
linux-postmarketos-qcom-msm8916
soc-qcom-msm8916
soc-qcom-msm8916-rproc
"
makedepends="devicepkg-dev"
source="deviceinfo modules-initfs"
subpackages="
$pkgname-nonfree-firmware:nonfree_firmware
"
_pmb_select="soc-qcom-msm8916-rproc"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
nonfree_firmware() {
pkgdesc="GPU/WiFi/BT/Modem/Video firmware"
depends="firmware-qcom-adreno-a300 msm-firmware-loader firmware-samsung-on7-wcnss-nv"
mkdir "$subpkgdir"
}
sha512sums="
f35bc86201b8def8c48d1620d02ec184ac34e5a47d344291941a3367a333505425b829df889a8378c0ed264240ba853959158fb6b18f02dabd68a6254cf1895e deviceinfo
2ec94ab06240419953494aede92263232e07745b8406923d39849c1a4b32bd135f4411243755e5f892d201e39dca10e8aa7b175b6c63361be094f6ba086a518f modules-initfs
"