3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
32 lines
1,017 B
Text
32 lines
1,017 B
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-samsung-matisseve
|
|
pkgdesc="Samsung Galaxy Tab 4 10.1"
|
|
pkgver=7
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="postmarketos-base mkbootimg linux-postmarketos-qcom-msm8916 soc-qcom-msm8916"
|
|
makedepends="devicepkg-dev"
|
|
source="deviceinfo modules-initfs"
|
|
subpackages="$pkgname-nonfree-firmware:nonfree_firmware"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="GPU/WiFi/BT/Modem/Video firmware"
|
|
depends="firmware-qcom-adreno-a300 msm-firmware-loader firmware-samsung-matisseve-wcnss-nv"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
sha512sums="
|
|
075a03ecbaf743db67e02408c2ffee3693718feac97b2cabf6f6b66db05390beef0ad96006cf91273a68cc55432c3524001a3cae22b28a02322a13e3d6f69e29 deviceinfo
|
|
a04d688a6df0cbb202598b558c5c9d3cf2ad39c8268f3055cc79c56fc7728be4a08366f67fddbb2b689e5bb23bec9a3821860114ea21f60a1d1cd0d6723dd53d modules-initfs
|
|
"
|