pmaports/device/testing/device-samsung-hlte/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

54 lines
1.4 KiB
Text

# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-samsung-hlte
pkgdesc="Samsung Galaxy Note 3"
pkgver=2
pkgrel=5
url="https://postmarketos.org"
license="MIT"
arch="armv7"
options="!check !archcheck"
depends="
linux-postmarketos-qcom-msm8974
mkbootimg
postmarketos-base
swclock-offset
"
makedepends="devicepkg-dev"
subpackages="
$pkgname-nonfree-firmware:nonfree_firmware
"
source="
bt-module-deps.conf
deviceinfo
modules-initfs
"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
nonfree_firmware() {
pkgdesc="GPU, Wi-Fi, Bluetooth firmware"
depends="
firmware-qcom-adreno-a330
firmware-samsung-hlte-bt
firmware-samsung-hlte-wifi
msm-firmware-loader
msm-modem
"
mkdir "$subpkgdir"
# This config makes sense only if non-free firmware is installed
install -Dm644 "$srcdir"/bt-module-deps.conf \
"$subpkgdir"/etc/modprobe.d/bt-module-deps.conf
}
sha512sums="
6cef5f8ae1785ac16e6fe84bfc861ac50cdfb94db35d764f44a25c960e123cb82f6e56f45362a5340c62a3d5ac225f2689afd4f6964cb88305a0892ba44214f0 bt-module-deps.conf
91f6f253275d3d312e120c345e69c40d3dc79ebd52bbe6405cdf82ece58d2c379d571b6be8131a4b51e3d683a420466e48a39b1a9d8b6617cbef713b597b6b65 deviceinfo
640f11d6cdea23ae5e183468aa9873f5ce091cac721d893866d5e46c19d77bcc6f5401cc0e6488c36d4da954fe94c3d7046f0bc2d299b656a06b540fab8d5e55 modules-initfs
"