3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
33 lines
1.1 KiB
Text
33 lines
1.1 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-samsung-heatqlte
|
|
pkgdesc="Samsung Galaxy Ace 4 (SM-G357FZ)"
|
|
pkgver=2
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="armv7"
|
|
options="!check !archcheck"
|
|
depends="postmarketos-base mkbootimg linux-postmarketos-qcom-msm8916 soc-qcom-msm8916 soc-qcom-msm8916-rproc"
|
|
makedepends="devicepkg-dev"
|
|
subpackages="$pkgname-nonfree-firmware:nonfree_firmware"
|
|
source="deviceinfo modules-initfs"
|
|
_pmb_select="soc-qcom-msm8916-rproc"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="GPU/WiFi/BT/Modem/Video firmware"
|
|
depends="firmware-qcom-adreno-a300 msm-firmware-loader firmware-samsung-heatqlte-wcnss-nv"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
sha512sums="
|
|
8fab423ea3b8b6a2475c0a4fb03466dcafbe5000553681bd5a5dc45d7e0a09c4cd54febb53b10331928aa6b4b2b3f9bd49642eb42ed46153c44cc8f90a050b10 deviceinfo
|
|
ef54a1b54c229c8152050d902b9690675490347c0308ddd7053305a578bd1a641dbb3a86bf95b5c3f2c7d3136e6ddf5444bb53e91aa513d2707f7f239f2ed43e modules-initfs
|
|
"
|