pmaports/device/testing/device-samsung-fortunaltezt/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

42 lines
1.1 KiB
Text

# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-samsung-fortunaltezt
pkgdesc="Samsung Galaxy Grand Prime (SM-G530Y)"
pkgver=2
pkgrel=1
url="https://postmarketos.org"
license="MIT"
arch="armv7"
options="!check !archcheck"
depends="
postmarketos-base
mkbootimg
linux-postmarketos-qcom-msm8916
soc-qcom-msm8916
soc-qcom-msm8916-rproc
"
makedepends="devicepkg-dev"
source="
deviceinfo
modules-initfs
"
subpackages="$pkgname-nonfree-firmware:nonfree_firmware"
_pmb_select="soc-qcom-msm8916-rproc"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
nonfree_firmware() {
pkgdesc="GPU/WiFi/BT/Modem/Video firmware"
depends="firmware-qcom-adreno-a300 msm-firmware-loader firmware-samsung-fortunaltezt-wcnss-nv"
mkdir "$subpkgdir"
}
sha512sums="
03007cde27317649e4f9bb488fa304967922531927cc07f8b31b7feb5a04ec43629fa92e5daab415cab9621a167e364e11736b566d1971ecb9ac7587d1a27d9e deviceinfo
0dcec6521708a8733aab879eb65047d3bf0ab562d4afb40fec2cff057a08b52b59940e1f9dea2f32519b2565af0399f724950c631ee45790a73199eb53c0653f modules-initfs
"