pmaports/device/testing/device-samsung-codina/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

36 lines
760 B
Text

# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-samsung-codina
pkgdesc="Samsung Galaxy Ace 2"
pkgver=2
pkgrel=4
url="https://postmarketos.org"
license="MIT"
arch="armv7"
options="!check !archcheck"
depends="mkbootimg postmarketos-base linux-postmarketos-stericsson"
makedepends="devicepkg-dev"
subpackages="
$pkgname-nonfree-firmware:nonfree_firmware
"
source="
deviceinfo
"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
nonfree_firmware() {
pkgdesc="WiFi/BT firmware"
depends="firmware-samsung-u8500"
mkdir "$subpkgdir"
}
sha512sums="
71c464e81685f6bae037812e19b2d79258e05e9114b1ff214184d2ccc8a0eae284d06cfc80ae17b75d596a97dbbf1a2aa37e90b8ae5b07e4dfd0c92dd9bf7d63 deviceinfo
"