3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
31 lines
785 B
Text
31 lines
785 B
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-pocketbook-614-plus
|
|
pkgdesc="PocketBook 614 Plus"
|
|
pkgver=1
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="armv7"
|
|
options="!check !archcheck"
|
|
depends="
|
|
linux-postmarketos-allwinner
|
|
u-boot-pocketbook-614-plus
|
|
postmarketos-base>=25-r1
|
|
"
|
|
makedepends="devicepkg-dev"
|
|
source="
|
|
deviceinfo
|
|
modules-initfs
|
|
"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
sha512sums="
|
|
d95408c6f66bd6b0fee985bce0ac618b21b4ea53d07028637afc71c061ad60981f77b131e2896c306cd525341a129e7525bd7a88e8eb255afd6f3e38c147ba01 deviceinfo
|
|
bccead09b413637b2ef20bf6eed96e29998b85c40b6c3250ac5ecad1b7529e1ad54ea490cd4b29c457d30cd7fdc1e5b30811903c228b1df07145f18cb96739cf modules-initfs
|
|
"
|