pmaports/device/testing/device-pine64-rock64/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

25 lines
647 B
Text

# Reference: <https://postmarketos.org/devicepkg>
# Maintainer: Timothy Valldeperas <tvall43@gmail.com>
pkgname=device-pine64-rock64
pkgver=3
pkgrel=3
pkgdesc="PINE64 ROCK64"
url="https://postmarketos.org"
license="MIT"
arch="aarch64"
options="!check !archcheck"
depends="postmarketos-base>=25-r1 linux-postmarketos-rockchip u-boot-rock64"
makedepends="devicepkg-dev"
source="deviceinfo"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
sha512sums="
f575316cf89aef2524ef86cbc51f43328193bf9f3e967f74d1942c1b5938ec9b2e3d49bb2e252bfce6ccdba7366c73d11ff29b090fe5c17331faf8a533eb1ef5 deviceinfo
"