pmaports/device/testing/device-pine64-a64lts/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

38 lines
1.1 KiB
Text

# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-pine64-a64lts
pkgdesc="PINE64 A64-LTS"
pkgver=1
pkgrel=1
url="https://postmarketos.org"
license="MIT"
arch="aarch64"
options="!check !archcheck"
subpackages="$pkgname-nonfree-firmware:nonfree_firmware"
depends="postmarketos-base linux-postmarketos-allwinner u-boot-sunxi u-boot-tools"
makedepends="devicepkg-dev"
source="
deviceinfo
uboot-script.cmd
"
build() {
devicepkg_build $startdir $pkgname
mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n postmarketos -d "$srcdir"/uboot-script.cmd "$srcdir"/boot.scr
}
package() {
devicepkg_package $startdir $pkgname
install -D -m644 "$srcdir"/boot.scr \
"$pkgdir"/boot/boot.scr
}
nonfree_firmware() {
pkgdesc="Wifi and Bluetooth firmware"
depends="linux-firmware-rtlwifi linux-firmware-rtl_bt firmware-pine64-rtl8723bt"
mkdir "$subpkgdir"
}
sha512sums="
b6fe933886888b453839084d2001de93f343472d1f4e2597914901692d9410d15202f790d92a3f70312e4ededd687f02edd79423ea7b9a9f831f6db57f9093fa deviceinfo
9f53b80ebc9cbbea488c75dc9b3abe374d5a5e6b756831dd5d298fd4af73450fedea5cc93381f93bbbdd3503cffd4ea5edb2a6836ea130fb408327ea4cf12576 uboot-script.cmd
"