cf69326222
[ci:ignore-count]
42 lines
1.1 KiB
Text
42 lines
1.1 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-oneplus-oneplus3
|
|
pkgdesc="OnePlus 3"
|
|
pkgver=1
|
|
pkgrel=11
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
subpackages="$pkgname-nonfree-firmware:nonfree_firmware"
|
|
depends="
|
|
postmarketos-base
|
|
linux-postmarketos-qcom-msm8996
|
|
mkbootimg
|
|
reboot-mode
|
|
soc-qcom-msm8996
|
|
"
|
|
makedepends="devicepkg-dev"
|
|
source="deviceinfo modules-initfs"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="OnePlus 3 nonfree firmware (GPU, modem, sound, camera, sensors, WiFi, bluetooth)"
|
|
depends="
|
|
firmware-oneplus-oneplus3
|
|
linux-firmware-ath10k
|
|
linux-firmware-qca
|
|
soc-qcom-msm8996-nonfree-firmware
|
|
"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
sha512sums="
|
|
16ee292fe7ff96b185ecca7041d7602ccd6eda6215dc5ea96e37eba31e9210ca43921df09b82c1b7e55af435b4de26932e14ec0951f0e244235ed5933dcfbc54 deviceinfo
|
|
cc0bbb074d5ca73910673b571546715d6cdf0195526ee7b873f1795c0181ca62b650ab9899d70b3e0589a6373a5c873c2056dd67f68980f348b45fad6b399dfa modules-initfs
|
|
"
|