pmaports/device/testing/device-oneplus-guacamole/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

31 lines
695 B
Text

# Maintainer: Caleb Connolly <caleb@connolly.tech>
# Co-Maintainer: Uclydde <julianbraha@gmail.com>
# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-oneplus-guacamole
pkgdesc="OnePlus 7 Pro"
pkgver=1
pkgrel=1
url="https://postmarketos.org"
license="MIT"
arch="aarch64"
options="!check !archcheck"
depends="
linux-postmarketos-qcom-sm8150
mkbootimg
postmarketos-base
"
makedepends="devicepkg-dev"
source="deviceinfo"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
sha512sums="
fe7aa3481235cd608642c71413fb288fbe4dc9e3ffdaf9f1375506be6f662dd7c13699e66e14cb23aedc752694bd0cccb9cc5af385aaa94fea4971f1a03fb18f deviceinfo
"