3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
68 lines
2 KiB
Text
68 lines
2 KiB
Text
# Maintainer: Jami Kettunen <jami.kettunen@protonmail.com>
|
|
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-oneplus-dumpling
|
|
pkgdesc="OnePlus 5T"
|
|
pkgver=4
|
|
pkgrel=6
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="
|
|
mkbootimg
|
|
postmarketos-base
|
|
"
|
|
makedepends="devicepkg-dev"
|
|
source="
|
|
deviceinfo
|
|
modules-initfs.alpine
|
|
modules-initfs.mainline
|
|
phoc.ini
|
|
"
|
|
subpackages="
|
|
$pkgname-kernel-alpine:kernel_alpine
|
|
$pkgname-kernel-mainline:kernel_mainline
|
|
$pkgname-nonfree-firmware:nonfree_firmware
|
|
$pkgname-phosh
|
|
"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
kernel_alpine() {
|
|
# FIXME: msm-modem-uim-selection hangs boot for some 20 seconds when installed with non-free FW
|
|
pkgdesc="Pure mainline kernel, unpatched Alpine linux-edge"
|
|
depends="linux-edge linux-firmware-none"
|
|
devicepkg_subpackage_kernel $startdir $pkgname $subpkgname
|
|
}
|
|
|
|
kernel_mainline() {
|
|
pkgdesc="Close to mainline kernel, plenty of working features and fixes"
|
|
depends="linux-postmarketos-qcom-msm8998 soc-qcom-msm8998"
|
|
devicepkg_subpackage_kernel $startdir $pkgname $subpkgname
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="Firmware for GPU, Wi-Fi, Bluetooth etc. (also needed for full disk encryption)"
|
|
depends="firmware-oneplus-msm8998"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
phosh() {
|
|
install_if="$pkgname postmarketos-ui-phosh"
|
|
# some scaling tweaks
|
|
install -Dm644 "$srcdir"/phoc.ini \
|
|
"$subpkgdir"/etc/phosh/phoc.ini
|
|
}
|
|
|
|
sha512sums="
|
|
4f85cbb805dbb7c8cf532c773239630e098570c6d9189a87296c8377c7310dc83ff9faad6b3a356a0d451d0bfc49a4e7ad252c8ebe3dbd05fa7115b2eb2e2505 deviceinfo
|
|
53472343462865f6b44897a079edc62dbbefe1b3ad0c7ceb02fa85a21d0162c0505321b516fc37a9fa7fcfe946cd17fd03a70b24bca302aa18773b576e5f14c9 modules-initfs.alpine
|
|
27fa563174768cf1c3b0568b9e5b84cfb5eb54ed29ff4788eaba829ca484a053dff46ae7f64741c59a9e7652970f5858e8bf42af5ae23fe6f37660777ca40d4a modules-initfs.mainline
|
|
2288f08a44aae5136c0c0c846501c2bd4bcb10f05454b40c6e4490d398385b8a7129216047b5eb7982ca6d62d3aa71f3e18bfb8661d0cd32c8a600685ca0da48 phoc.ini
|
|
"
|