3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
55 lines
1.6 KiB
Text
55 lines
1.6 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-oneplus-bacon
|
|
pkgver=3
|
|
pkgrel=2
|
|
pkgdesc="OnePlus One"
|
|
url="https://postmarketos.org"
|
|
arch="armv7"
|
|
license="MIT"
|
|
depends="
|
|
lk2nd-msm8974-appended
|
|
mkbootimg
|
|
postmarketos-base
|
|
"
|
|
makedepends="devicepkg-dev"
|
|
subpackages="
|
|
$pkgname-kernel-downstream:kernel_downstream
|
|
$pkgname-kernel-mainline:kernel_mainline
|
|
$pkgname-nonfree-firmware:nonfree_firmware
|
|
"
|
|
source="deviceinfo modules-initfs.mainline 90-android-touch-dev.rules"
|
|
options="!check !archcheck"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
install -Dm644 "$srcdir"/90-android-touch-dev.rules \
|
|
"$pkgdir"/etc/udev/rules.d/90-android-touch-dev.rules
|
|
}
|
|
|
|
kernel_downstream() {
|
|
pkgdesc="Downstream kernel"
|
|
depends="linux-oneplus-bacon msm-fb-refresher"
|
|
devicepkg_subpackage_kernel $startdir $pkgname $subpkgname
|
|
}
|
|
|
|
kernel_mainline() {
|
|
pkgdesc="Close to mainline kernel"
|
|
depends="linux-postmarketos-qcom-msm8974"
|
|
devicepkg_subpackage_kernel $startdir $pkgname $subpkgname
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="GPU, Wi-Fi firmware"
|
|
depends="firmware-qcom-adreno-a330 firmware-oneplus-bacon"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
sha512sums="
|
|
28ba572e6e45383e5a55670977195235dab098439987f57aa02fa2bb4865877bf2156f665301e25af051742e828f15cae74ee2de306cfc45d092dedd6a83bac2 deviceinfo
|
|
fd639faebbee2c0c2c227710678376e0d039b7d96a62103f7ba7e6304d7060023f09064918e93a125465d20d125c0334225680521a7aeae5a43d77d7360c180c modules-initfs.mainline
|
|
65e9ee7352b1dc39d99ea411eb0ed9c56f9975230907db5add3a1b4146cdf6f227c934052dab38a1937ed67d67585f28fb7410f10a1bec9dd5e4eb69d7253515 90-android-touch-dev.rules
|
|
"
|