pmaports/device/testing/device-odroid-hc2/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

61 lines
1.8 KiB
Text

# Reference: <https://postmarketos.org/devicepkg>
# Unmaintained: no maintainer
pkgname=device-odroid-hc2
pkgdesc="ODROID HC2"
pkgver=1
pkgrel=1
url="https://postmarketos.org"
license="MIT"
arch="armv7"
options="!check !archcheck"
depends="linux-edge
postmarketos-base
u-boot-odroid
u-boot-tools
"
makedepends="devicepkg-dev"
subpackages="$pkgname-nonfree-firmware:nonfree_firmware $pkgname-tools"
_commit="42ac93dcfbbb8a08c2bdc02e19f96eb35a81891a"
source="deviceinfo modules-initfs uboot-script.cmd install-rootfs-hdd.sh"
build() {
devicepkg_build $startdir $pkgname
mkimage \
-A arm \
-O linux \
-T script \
-C none \
-a 0 \
-e 0 \
-n postmarketos \
-d "$srcdir"/uboot-script.cmd \
"$srcdir"/boot.scr
}
package() {
devicepkg_package $startdir $pkgname
install -Dm644 "$srcdir"/boot.scr \
"$pkgdir"/boot/boot.scr
}
nonfree_firmware() {
pkgdesc="U-Boot, Samsung JPEG encoder, and Realtek firmware, required for a bootable system"
depends="firmware-odroid-hc2 linux-firmware-rtl_nic linux-firmware-other linux-firmware-s5p-mfc"
mkdir "$subpkgdir"
}
tools() {
pkgdesc="ODROID HC2 tools"
depends="rsync e2fsprogs-extra"
mkdir "$subpkgdir"
install -Dm744 "$srcdir"/install-rootfs-hdd.sh \
"$subpkgdir"/usr/bin/install-rootfs-hdd
}
sha512sums="
2aff998527535760d04b338d59976408a1d852ba38dfbdff305ec028030d419259cb1b9491b8e54a3621d147f9e8c1a797ed2a3784da7f25d2a92aa60882d027 deviceinfo
228726f7afca55b02e4d452904d8490cf15957edd59cc87274d89c8589f9d15044db87a4413053243e66aa1b22860cfda052b5b95395effaf3aaf4d1770d3fd3 modules-initfs
7e5056f648a81d0784b1b3a641e2f79c22d2b570c7f00092236b301b1545eefca3a6a353c1ad308114f66ac68481f1491df42ca5c6f8297c76e5ee0fa7af178f uboot-script.cmd
09a2191dce5b5c8fdf80c4473d9773a51f2c633db51477f2f64983dd030d7800fd80999a228ec7efe3f9feafeba35902bff68cf95e6ae59048dc64424f402b63 install-rootfs-hdd.sh
"