pmaports/device/testing/device-nokia-leo/APKBUILD
Nikita Travkin fa3a734875
device/msm8916*: Generate extlinux.conf for armv7 devices (MR 4855)
Commit fe54a7be4 ("device/msm8916*: Generate extlinux.conf (MR 4826)")
updated most users of msm8916 kernel to generate extlinux.conf.

Unfortunately the commands used to bulk-make changes only affected
aarch64 users of the kernel package and armv7 users were missed.

Apply the same changes to all armv7 users of msm8916 kernel too.

[ci:ignore-count]
2024-02-24 16:09:24 +05:00

60 lines
1.8 KiB
Text

# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-nokia-leo
pkgdesc="Nokia 6300 4G"
pkgver=2
pkgrel=0
url="https://postmarketos.org"
license="GPL-2.0-only"
arch="armv7"
options="!check !archcheck"
depends="
linux-postmarketos-qcom-msm8916
mkbootimg
postmarketos-base
soc-qcom-msm8909
soc-qcom-msm8916-rproc
"
_pmb_select="soc-qcom-msm8916-rproc"
subpackages="$pkgname-nonfree-firmware:nonfree_firmware"
makedepends="devicepkg-dev mipi-dbi-cmd"
_panel="nokia,leo-gc9305-hlt-24-panel"
source="
$_panel.txt
00-nokia-leo-display.files
deviceinfo
modules-initfs
"
build() {
devicepkg_build $startdir $pkgname
mkdir -p "$builddir"
mipi-dbi-cmd "$builddir"/"$_panel".bin \
"$srcdir"/"$_panel".txt
}
package() {
devicepkg_package $startdir $pkgname
# Package display init sequence
install -Dm644 "$builddir"/"$_panel".bin -t \
"$pkgdir"/lib/firmware/
install -Dm644 "$srcdir"/00-nokia-leo-display.files -t \
"$pkgdir"/usr/share/mkinitfs/files/
}
nonfree_firmware() {
pkgdesc="GPU/WiFi/BT/Modem/Video firmware"
depends="
firmware-qcom-adreno-a300
msm-firmware-loader
firmware-nokia-sparkler-venus
firmware-nokia-sparkler-wcnss-nv
"
mkdir "$subpkgdir"
}
sha512sums="
8583c7d5a97c4efedff3ec554cf682d815fd7b83140c2cab9eec4b6e2e735ce3c012bc3bd97f8bc75adc3483f76ce83a5bf1090d4f3e73a327efc64ca9eca5a7 nokia,leo-gc9305-hlt-24-panel.txt
c9985232e5e64ddb0906b053e5024c87fa62cc1bcb254260e1ef6afb43d384196e09d41287143bcba61dff616dd6b562a5ca335dbe592fcd8c954642b8085f38 00-nokia-leo-display.files
d28c316bace09629d13bf93261cbaaf2c6c2c9f3f0adb891e4055d4da721b881a9b883d13683989f483b9a5ef9a283974d6e4d1f7179928d768c1424c7fcc449 deviceinfo
d5dfe844a45cfc4e0844e43b8fb3e1bbcb155e06430188f8d5059fc5ce3c4100fde7f1580b1b54c5318f40d238736b233463582e55b9dd25654e40539e11ed39 modules-initfs
"