3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
38 lines
1.1 KiB
Text
38 lines
1.1 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-motorola-surnia
|
|
pkgdesc="Motorola Moto E (2nd Gen)"
|
|
pkgver=3
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="postmarketos-base mkbootimg linux-postmarketos-qcom-msm8916
|
|
soc-qcom-msm8916 soc-qcom-msm8916-rproc"
|
|
makedepends="devicepkg-dev"
|
|
source="deviceinfo modules-initfs"
|
|
|
|
subpackages="
|
|
$pkgname-nonfree-firmware:nonfree_firmware
|
|
"
|
|
|
|
_pmb_select="soc-qcom-msm8916-rproc"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="GPU/Wi-Fi/Bluetooth/Video(/Modem) firmware"
|
|
depends="firmware-qcom-adreno-a300 msm-firmware-loader firmware-motorola-surnia-wcnss-nv firmware-motorola-harpia-venus"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
sha512sums="
|
|
80a650fa5b941e063f41d474ba92573188deff7bf51cb3266817736a74e6b635f533fa93cc66b8f70813c6694454e2f68e7d990bd17560fa8d9922b1daccf516 deviceinfo
|
|
44df8245209d15e16e5114874e22160383861988b0bd1b2e2faca27c817cc03f431a387e8cc5a708ab2cfcc67b04f204043cdaaf898552588ea8feb18755b0a9 modules-initfs
|
|
"
|