3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
63 lines
1.2 KiB
Text
63 lines
1.2 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
# Maintainer: exkc <exxxxkc@getgoogleoff.me>
|
|
pkgname=device-mangopi-mq-pro
|
|
pkgdesc="MangoPi MQ-Pro"
|
|
pkgver=2
|
|
pkgrel=3
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="riscv64"
|
|
# pmb:strict: avoid grub-related install error during build with pmbootstrap
|
|
options="!check !archcheck pmb:strict"
|
|
depends="
|
|
linux-postmarketos-allwinner-d1
|
|
postmarketos-base
|
|
u-boot-mangopi-mq-pro
|
|
"
|
|
makedepends="
|
|
devicepkg-dev
|
|
grub
|
|
grub-efi
|
|
"
|
|
source="deviceinfo"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
|
|
grub-mkimage \
|
|
--prefix="/grub" \
|
|
--output="bootriscv64.efi" \
|
|
--format="riscv64-efi" \
|
|
--compression="xz" \
|
|
\
|
|
all_video \
|
|
cat \
|
|
configfile \
|
|
disk \
|
|
echo \
|
|
efi_gop \
|
|
fat \
|
|
ext2 \
|
|
gzio \
|
|
help \
|
|
iso9660 \
|
|
linux \
|
|
ls \
|
|
normal \
|
|
part_gpt \
|
|
part_msdos \
|
|
search \
|
|
search_label \
|
|
test \
|
|
true
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
install -Dm644 "$srcdir"/bootriscv64.efi \
|
|
"$pkgdir"/boot/efi/boot/bootriscv64.efi
|
|
}
|
|
|
|
sha512sums="
|
|
0c3c3d96645fc169e69450ad8b2b05f042696fc2d8cff41101d343be15f2c1b2c1e010275338af3715be8f00e0963960d78ac8ad0e047c3afa83560429cf77bd deviceinfo
|
|
"
|