3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
38 lines
1.1 KiB
Text
38 lines
1.1 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-lenovo-a6020a40
|
|
pkgdesc="Lenovo Vibe K5"
|
|
pkgver=2
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="postmarketos-base mkbootimg linux-postmarketos-qcom-msm8916
|
|
soc-qcom-msm8939 soc-qcom-msm8916-rproc"
|
|
makedepends="devicepkg-dev"
|
|
source="deviceinfo modules-initfs"
|
|
subpackages="
|
|
$pkgname-nonfree-firmware:nonfree_firmware
|
|
"
|
|
_pmb_select="soc-qcom-msm8916-rproc"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="GPU/WiFi/BT/Modem/Video firmware"
|
|
depends="firmware-qcom-adreno-a420 msm-firmware-loader
|
|
firmware-lenovo-a6020-wcnss-nv
|
|
firmware-lenovo-a6020-venus"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
sha512sums="
|
|
e938936b3d01f085ee9b7b4c44426df3a617c3441ff8d4864db910d1aa6894cbe7a5502af7010d4c95655772bb63a97e0a34504910a767ea4b74dfe30e2bd27f deviceinfo
|
|
36791d00fdb1856c8b2e25f7ce675cd177262809348b218dd66f7e55e92f5f6e22699860d9a667d12169da75685787074a4d06d5cf49f64d5cb83be74ccf0533 modules-initfs
|
|
"
|