3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
64 lines
1.5 KiB
Text
64 lines
1.5 KiB
Text
# Maintainer: Yang Xiwen <forbidden405@outlook.com>
|
|
# Co-Maintainer: Nikita Travkin <nikita@trvn.ru>
|
|
|
|
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-generic-zhihe
|
|
pkgdesc="A generic device package for various MSM8916-based dongles(namely zhihe)"
|
|
pkgver=2
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="GPL"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="
|
|
mkbootimg
|
|
postmarketos-base
|
|
soc-qcom-msm8916
|
|
soc-qcom-msm8916-rproc
|
|
"
|
|
_pmb_select="soc-qcom-msm8916-rproc"
|
|
makedepends="devicepkg-dev"
|
|
source="deviceinfo"
|
|
subpackages="
|
|
$pkgname-nonfree-firmware:nonfree_firmware
|
|
$pkgname-kernel-ufi001c:kernel_ufi001c
|
|
$pkgname-kernel-uf896:kernel_uf896
|
|
$pkgname-kernel-uz801:kernel_uz801
|
|
"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="WiFi/BT/Modem/Video firmware"
|
|
depends="msm-firmware-loader
|
|
firmware-qcom-msm8916-venus"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
kernel_ufi001c() {
|
|
pkgdesc="UFI103S / UFI-001C(B) / UFI003"
|
|
depends="linux-postmarketos-qcom-msm8916"
|
|
devicepkg_subpackage_kernel $startdir $pkgname $subpkgname
|
|
}
|
|
|
|
kernel_uf896() {
|
|
pkgdesc="UF896"
|
|
depends="linux-postmarketos-qcom-msm8916"
|
|
devicepkg_subpackage_kernel $startdir $pkgname $subpkgname
|
|
}
|
|
|
|
kernel_uz801() {
|
|
pkgdesc="UZ801 V3.0"
|
|
depends="linux-postmarketos-qcom-msm8916"
|
|
devicepkg_subpackage_kernel $startdir $pkgname $subpkgname
|
|
}
|
|
|
|
sha512sums="
|
|
94713427c83db27c6523c6a022aa1b28526db05be2a6f43d9a2f22acee6dde3ca997736f1673e5962939c300f92a286aa7e2845c266bc96b4cedfd562edfc1c1 deviceinfo
|
|
"
|