3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
62 lines
1.1 KiB
Text
62 lines
1.1 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-dongshanpi-nezhastu
|
|
pkgdesc="DongshanPi NeZha STU"
|
|
pkgver=1
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="riscv64"
|
|
# pmb:strict: avoid grub-related install error during build with pmbootstrap
|
|
options="!check !archcheck pmb:strict"
|
|
depends="
|
|
linux-postmarketos-allwinner-d1
|
|
postmarketos-base
|
|
u-boot-dongshanpi-nezhastu
|
|
"
|
|
makedepends="
|
|
devicepkg-dev
|
|
grub
|
|
grub-efi
|
|
"
|
|
source="deviceinfo"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
|
|
grub-mkimage \
|
|
--prefix="/grub" \
|
|
--output="bootriscv64.efi" \
|
|
--format="riscv64-efi" \
|
|
--compression="xz" \
|
|
\
|
|
all_video \
|
|
cat \
|
|
configfile \
|
|
disk \
|
|
echo \
|
|
efi_gop \
|
|
fat \
|
|
ext2 \
|
|
gzio \
|
|
help \
|
|
iso9660 \
|
|
linux \
|
|
ls \
|
|
normal \
|
|
part_gpt \
|
|
part_msdos \
|
|
search \
|
|
search_label \
|
|
test \
|
|
true
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
install -Dm644 "$srcdir"/bootriscv64.efi \
|
|
"$pkgdir"/boot/efi/boot/bootriscv64.efi
|
|
}
|
|
|
|
sha512sums="
|
|
340c7d568227d1fcba48abd22add3a68d148981d55ef10fcbd1ce860c3d9784d20930a1b20bb89b55761b5dba26fa1ad98453d3288cc58c63056b121bc7ad6d2 deviceinfo
|
|
"
|