pmaports/device/testing/device-cubietech-cubieboard/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

32 lines
986 B
Text

# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-cubietech-cubieboard
pkgdesc="Cubietech Cubieboard"
pkgver=1
pkgrel=1
url="https://postmarketos.org"
license="MIT"
arch="armv7"
options="!check !archcheck"
depends="
linux-edge
postmarketos-base
u-boot-sunxi
"
makedepends="devicepkg-dev"
source="deviceinfo modules-initfs extlinux.conf"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
install -Dm644 "$srcdir"/extlinux.conf \
"$pkgdir"/boot/extlinux/extlinux.conf
}
sha512sums="
b96257f819ef38fc3dabc09db4ebabd9e52ce99f79a2ea11db95a4f6bb52fda38c45840f2537132b8d34eeb78e78287d9bd4941f29300170b0c29bb37f6b3008 deviceinfo
4218f3e3b4aa3d3dbacbfe4dbe997bce8a9bf9f077ad78df21c0754b3789e0dd8533e2c9a4ee9fffb0069ee08bf51977cc0a11308c30cf7551fec0b38e36881e modules-initfs
43e3df861ee9e92907fcf6f93152ee873d81149ab1d96d83816b7d7337a1280945853d6fa77940e201c29584758e37076832209ce9cab520e2ba100af6f6229f extlinux.conf
"