3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
45 lines
1.3 KiB
Text
45 lines
1.3 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-bq-piccolo
|
|
pkgdesc="BQ Aquaris M5"
|
|
pkgver=6
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="postmarketos-base mkbootimg linux-postmarketos-qcom-msm8916
|
|
soc-qcom-msm8939 soc-qcom-msm8916-rproc"
|
|
makedepends="devicepkg-dev"
|
|
source="deviceinfo modules-initfs phoc.ini"
|
|
subpackages="
|
|
$pkgname-nonfree-firmware:nonfree_firmware
|
|
$pkgname-phosh
|
|
"
|
|
_pmb_select="soc-qcom-msm8916-rproc"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="GPU/WiFi/BT/Video(/Modem) firmware"
|
|
depends="firmware-qcom-adreno-a420 msm-firmware-loader
|
|
firmware-bq-piccolo-venus firmware-bq-piccolo-wcnss-nv"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
phosh() {
|
|
install_if="$pkgname postmarketos-ui-phosh"
|
|
install -D -m644 "$srcdir"/phoc.ini \
|
|
"$subpkgdir"/etc/phosh/phoc.ini
|
|
}
|
|
|
|
sha512sums="
|
|
fad7d6f1289b8385889dd742ef1f3c07fdea94829eef837b03d3a8712d99bda71dd5a80cead2aa923184ab3ce1cc3a410483fec21dfd91265745490f9d09247e deviceinfo
|
|
d7ba0b86dc573d0d57591399ec71c76169730b169546d1692910c3e04913100f8bfa534100dab8d5ad302d2a539fb64b040a6fb26979f41c8e7b76b596427afd modules-initfs
|
|
08a84d731ab0b33b8ec21001331e9c2261a039d3f137eb8bd2f580abea5cfb78706d95443b3e34f9ea3c73e15bcc75038a830402adc7e05636c03e9ce3581eb7 phoc.ini
|
|
"
|