pmaports/device/testing/device-asus-z00l/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

37 lines
1.1 KiB
Text

# Reference: <https://postmarketos.org/devicepkg>
# Maintainer: Antony J.R. <antonyjr@pm.me>
pkgname=device-asus-z00l
pkgdesc="ASUS Zenfone 2 Laser (720p)"
pkgver=6
pkgrel=1
url="https://postmarketos.org"
license="MIT"
arch="aarch64"
options="!check !archcheck"
depends="postmarketos-base mkbootimg linux-postmarketos-qcom-msm8916
soc-qcom-msm8916 soc-qcom-msm8916-rproc"
makedepends="devicepkg-dev"
source="deviceinfo modules-initfs"
subpackages="
$pkgname-nonfree-firmware:nonfree_firmware
"
_pmb_select="soc-qcom-msm8916-rproc"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
nonfree_firmware() {
pkgdesc="GPU/WiFi/BT/Modem/Video firmware"
depends="firmware-qcom-adreno-a300 msm-firmware-loader firmware-asus-z00l-wcnss-nv"
mkdir "$subpkgdir"
}
sha512sums="
b090f56a03713f8bed2b28d2c9fa559b0f190bd65973a7d4d5ed103334917d39bf1235f45d3bbc5a11a50971fad64fc26f8b26acd809596dcabb6e7aba95e20e deviceinfo
868ea93ae3be2a9b2be7cac329b66b7be6f7e72ade7bd111d7b354dcd81a23f4e0d7f4dc617f8d1321a14bbac803778150cce1bff21cd0ed3846803f3d2ed70c modules-initfs
"